Survey123 Forms not functioning (fully) in Collector

181
2
Jump to solution
06-28-2019 09:23 AM
JasonStewart2
New Contributor II

I'm fairly new to using Survey123 and recently placed some forms my colleague created in a Collector feature service. I can collect with them and everything works smoothly except that I lost some of the pick list functionality in Collector. The smaller pick lists (Yes,No questions) are still pick lists, anything with more than two options no longer function. I can manually input data and it works great but I'd like to be able to use the pick lists. Is it a coding problem or does Collector just not have the functionality?

0 Kudos
1 Solution

Accepted Solutions
DerekLaw
Esri Community Moderator

Hi Jason,

> Is it a coding problem or does Collector just not have the functionality?

Yes, this is expected behavior. The "smart form" functionality you've enabled in Survey123 does not work within Collector - as they are two separate and different apps.

Enhanced support for smart forms in Collector is planned for a future release, please vote for the enhancement https://community.esri.com/ideas/9131 

Hope this helps,

View solution in original post

2 Replies
DerekLaw
Esri Community Moderator

Hi Jason,

> Is it a coding problem or does Collector just not have the functionality?

Yes, this is expected behavior. The "smart form" functionality you've enabled in Survey123 does not work within Collector - as they are two separate and different apps.

Enhanced support for smart forms in Collector is planned for a future release, please vote for the enhancement https://community.esri.com/ideas/9131 

Hope this helps,

JasonStewart2
New Contributor II

Thanks, that answers my question. I posted this in the Survey123 forum as well and was suggested to use the "forms" function in the feature service to create the pick lists in Collector. Although not as smooth it is working even though I think we will just stick to using both apps to collect our data for the time being. I'll go vote as well.