Problems downloading basemap offline in Collector

4560
6
02-16-2016 01:34 PM
JoyParikh1
New Contributor

Hi- I'm hoping someone can provide some guidance.   In Collector, I'm trying download my basemap (esri imagery with no labels) to prepare for offline data collection.  However, when I try to "Download a Basemap" in collector and "choose work area", I get the following error message:

"Map Download Failed. A layer does not have the correct editing capabilities. The operation could not be completed. (AppFramework error 9).

I have 7 other feature services as part of my ArcGIS Online map.  Each of the feature services  all enabled for offline mode (sync).

Any help is much appreciated. I'm stuck!

Thank you!

Joy

0 Kudos
6 Replies
RandyBurton
MVP Regular Contributor

From the error message, I suggest checking the properties of your feature layers.  They should be editable at the layer level - editors can edit, add, etc.

In your map, you can configure the pop-up to disable or limit editing of a layer.  There is also an option in your map to disable editing on a layer. Collector maps should have at least one editable layer.

0 Kudos
joyparikh
New Contributor II

Thanks, Randy, for the tips.  I double-checked and there are 2 feature layers that are editable (sync, upload, edit, query, create, delete) in the Collector Map.   

I also made sure in the ArcGIS Online map that these 2 layers are enabled for editing. 

But when I try to download my basemap in Collector, I'm still getting the same error:  "Map Download Failed. A layer does not have the correct editing capabilities. The operation could not be completed. (AppFramework error 9)."

Any other suggestions on how to resolve are much appreciated!   My goal is to be able to download a basemap so I can collect field data offline (some of the fieldwork is out of the reach of a signal).

Thanks!!

0 Kudos
RandyBurton
MVP Regular Contributor

For debugging, I would suggest first to make a copy of your map. Then delete one layer at a time to identify any bad layers. When the map starts working, then you can try adding back any layers that were deleted just to verify any problems with the layer.

Alternatively, start with a new map and add layers one at a time, verify the map works, then add the next.

HollyBaun1
New Contributor II

I had a similar problem, only the error messages said: " The map .... failed to download with the message: Unable to create replica. Please check your parameters., Exporting data for layer 7 failed." I also got the same message with layer 8 failing as well. Both times the download was hung up and I had restart my Android device to cancel the download.  I removed all the non-critical reference layers from my web map and was able to successfully download, edit and sync.  This was using a topographic basemap. However, when I changed the web map to imagery with labels, I am getting an error that says " Attempt to invoke interface method 'java.lang.String ix.c()' on a null object reference". It keeps looping back with the same error. Restarting device failed to clear the error message.  After I started a new download area, that was successful, the error code cleared. It is frustrating to have all of these little errors pop up.                

deleted-user-e85gf8f4p25S
New Contributor

Hey Holly, did you ever find a solution to the error you got when trying to download imagery? Thanks!

0 Kudos
JoshuaTanner2
New Contributor III

I saw the same error message recently when troubleshooting issues with Collector.  It turned out the basemap specified in the web map was a vector tile basemap, which (to my knowledge) is not supported in Collector yet.  To those experiencing the same issue, change your web map basemap to a raster tile service basemap and try the download again.  Also, the error is only displayed on Android.  iOS users will experience an app crash with no error message.

0 Kudos