Select to view content in your preferred language

Offline Mode missing from basemaps settings

08-25-2016 05:32 AM
Occasional Contributor

I was previously able to take maps offline that I created  on ArcGIS Online. Now, when I go into Collector the cloud icon that allows you to download the map is gone. If I view the map settings on AGOL, the "Offline Mode" is not shown. The only difference that I can think of is I used to have a free account because we had the yearly maintenance program. We then purchased 5 user account license, but the original account is still one of the 5 and is the administrator. I created a new map, and the "Offline Mode" is shown in the settings with the check box shown. If I enable Offline with this map, that Offline option is available in Collector. Anyone else experience this? I know this is sort of unique. I'm just trying to avoid having to rebuild my maps. Any help is greatly appreciated. I guess I'm just rying to figure out why the entire "Offline Mode" is missing from my basemap.

6 Replies
Occasional Contributor III


Do you have an editable layer in your map? I've found not having an editable layer prevents me from having the map off-line

0 Kudos
Occasional Contributor III

Did you delete the Tile Package in AGOL that goes with your published Tile Layer? If so you won't be able to take the Tile Layer offline anymore.

0 Kudos
Occasional Contributor

Thank you for your replies. I believe it was my mistake. I had a map with some layers, and then created another map and used one of those same layers (valves). I then changed the settings in that layer and it disabled the option of being able to download it. Thank you both for your help. 

New Contributor III

I am having the problem where I download my offline work area once, but then if I need to download a new different offline work area, or if I update the map in ArcGIS Online, then need to download it for offline use again - I am missing the download button (the little cloud one). It seems like I only get one shot at downloading an offline area which is really not helping me much.

Any suggestions?

by Anonymous User
Not applicable

I experienced this problem yesterday, had to call ESRI today. We found a work around but the main issue; if I create a brand new map in AGOL, the option to take the layers offline is absent and we could not figure out why. All the layers in the map had sync enabled and were editable etc. But of course the download option in Collector was not available.

Eventually I took a map which worked previously, and added the same layers to it, renamed it, and it worked fine. The download option came up in Collector etc.

The Rep is hoping it is a one time, one off situation. But if I cannot create a new map and see the option to download, and have to use only previous map, I am a little dubious that others won't have the same problem. But hopefully the work around helps.


0 Kudos
New Contributor

At least in spring 2024, I think there might be a bug causing this problem. This week I've created several Hosted Feature Layers and several Web Maps and had difficulty getting both the Web Map Offline settings to appear, and the ability to edit in Field Maps. All the settings for my layers and Web Map seem proper. I solve the problem by unchecking and rechecking Enable Editing in my new Hosted Feature Layer(s) and then Save-As a new Web Map.  After a few tries the Offline settings magically appears, along with my ability to edit the layer in Field Maps.

I learned to avoid unchecking "Enable Sync."  Whenever I unchecked Enable Sync and Saved I could not re-enable Sync; it would say, "Save wasn't successful. Try again later." That layer then then seemed forever broken and I would need to make a new one.

0 Kudos