Not All Fields of Hosted Feature Layer Editable

08-12-2019 07:00 PM
New Contributor II

I have a hosted feature layer that I'm accessing through Collector which does not display 2 date fields when I attempt to edit an existing feature or create a new feature. These fields are visible when viewing details of features. All other fields, only 11 in total, are behaving as normal. Editing is enabled (add, update, and delete) with editors able to see and edit all features. Sync and Data Export are both enabled, as well.

I shared the feature to my AGOL account as a hosted feature layer through ArcPro. In ArcPro I have double checked that the fields are not marked as Read Only, both in the original, local layer prior to sharing, and in the newly AGOL hosted layer. I tried to host the layer once more, creating a separate layer accessed through a new map, but found the same issue. This is the case for both offline and online instances.

This is happening on Android (version 18.0.3, build 1033), as well as iOS (version 19.1.0, build 2666).

Any ideas?


I checked the pop-up configuration on my map and found that the two fields were checked to be displayed (which is congruent with the fact that I could see them in the pop-up). They were also checked to be editable (which is incongruent with the fact that I could not see them once editing). I re-ordered the problem fields higher in the field list, then un-checked and re-checked them for display and edit. That seems to have worked, for whatever reason.

Tags (1)
0 Kudos
0 Replies