No GNSS metadata for Trimble R1?

1288
5
Jump to solution
07-07-2017 10:33 AM
by Anonymous User
Not applicable

I am having issues with getting the Trimble R1 to send the GNSS metadata to collector via NMEA. I have used the Python utility from ESRI to bake in the necessary attribute fields to my data

collector-tools/CollectorUtils at master · Esri/collector-tools · GitHub 

At that point from ArcGIS desktop I publish the service to our AGOL account, and build the collector map. Next I connect my Trimble R1 to my Ipad via Bluetooth. I open GNSS Status App and the receiver is connected and displaying SBAS corrected accuracy. In the NEMA setting I select GGA, GSA, GST, GSV, RMC, VTG as recommended by this post

GPS receiver support—Collector for ArcGIS | ArcGIS 

Next I switch over to collector and record my point. The reported accuracy in Collector remains higher than the GNSS status (no surprise there, it's a known bug) The attributes that fill in are Receiver name(= Ipad Air 2), lat, long, altitude, fix time. It looks like it is not receiving NEMA information from the R1...

To troubleshoot I have tried the steps in this thread about collecting into the GNSS capture map.

Why won't Collector record the NMEA metadata from the Trimble R1 receiver? 

I have also tried to collect while connected to a Garmin Glo, as well as connected to the receivers in airplane mode. All yield the same GNSS metadata results as above.

Environment --

Ipad Air on IOS 10.3.2

Collector 17.0.1

Trimble R1 5.04

GNSS Status App 2.0.11.21

Any ideas?

0 Kudos
1 Solution

Accepted Solutions
by Anonymous User
Not applicable

Solved:

After making sure to select the R1 antenna as the provider in the collector app, and disabling the position averaging setting the attributes populate just fine. The Collector Utils python script provided by ESRI does not add the average horizontal and Average vertical positions fields by default. I had to modify the script to add those specific fields. Everything looks like it is working now.

View solution in original post

0 Kudos
5 Replies
Kylie
by Esri Regular Contributor
Esri Regular Contributor

Hi Jonny -- Have you selected your R1 in Collector and created a location profile? See Use high-accuracy GPS—Collector for ArcGIS | ArcGIS 

0 Kudos
by Anonymous User
Not applicable

Thanks for the response Kylie,

Shortly after I posted I realized I wasn't selecting the R1 as the receiver (Doh!). After I selected that, the name for the receiver shows up as  the name of my trimble receiver in the attributes, still no other horizontal accuracy etc being populated. At this point I tried the same exact configuration on android and it seems to work perfectly.

In an attempt to get IOS working I setup a location profile as well

GCS ITRF 2008

to

WGS 1984 Web Mercator Aucilary Sphere

Transformation:

ITRF_2008_To_NAD_1983_2011+WGS_1984_(ITRF08)_To_NAD_1983_2011

Any more suggestions?

0 Kudos
by Anonymous User
Not applicable

Solved:

After making sure to select the R1 antenna as the provider in the collector app, and disabling the position averaging setting the attributes populate just fine. The Collector Utils python script provided by ESRI does not add the average horizontal and Average vertical positions fields by default. I had to modify the script to add those specific fields. Everything looks like it is working now.

0 Kudos
Kylie
by Esri Regular Contributor
Esri Regular Contributor

I'm glad you got it working. Yes, you are correct that the GPS averaging fields aren't yet in the add_gnss_metadata_fields Collector Utils script. We are working to update it.

0 Kudos
Kylie
by Esri Regular Contributor
Esri Regular Contributor

The script is now updated with the averaging fields. I knew we were close to done with that

0 Kudos