Layer fails to load in Collector

5717
12
04-24-2019 02:38 AM
ColinBourne1
New Contributor II

Hi All,

I have a layer that fails to load within the new version of Collector (Apple device). I get the following error message

Domain: com.esri.arcgis.runtime.error

Code: 2

Description: Invalid argument

The layer loads within Collector Classic and on other platforms (Android).

Just wondering if anyone else has had this problem or knows what the code is referring to?

Cheers

Colin

0 Kudos
12 Replies
SusanBorchardt
New Contributor

I am having the same problem, collector and layers work fine on android. Map opens on Apple but collection layer has following error "Layer failed to load"

Thanks,

Sue

0 Kudos
MartinAncilleri
New Contributor

We are also seeing the same issue. 

Some Layers are failing to load on the new Collector App but ok on the Collector Classic. 

0 Kudos
by Anonymous User
Not applicable

Anyone find an answer for this issue? It was just brought to my attention today by one of our users. We just recently received and implemented new iPads and the data for the web map all shows up in the Classic Collector but in the New Collector, we get some errors on two or three of the Feature Classes saying "Failed to Load".  They all load fine in the Web Map. We are running our own organizational hosted services on 10.6.1 ArcGIS Server. Thanks for anyone who can assist.

0 Kudos
SusanBorchardt
New Contributor

I called esri and got a tech guy on the line and he fixed the problem. I am attaching below the recap of what was done to get the layers to function.

To recap our phone call, you were seeing an issue in Collector for iOS 19.0.1 where one specific layer would not load in any web map. When you click the layer, you were receiving the error: "Code 2. Invalid argument". To fix this issue, we inspected the fields list in ArcGIS Online. We noticed that some fields had domains. We added a space to one value in the "Code" field in each domain, removed it, and saved the domain. On the backend, this changes the name of the reference to the domain. Like I mentioned, there was a known issue with the naming convention of these references that became apparent with the last release of ArcGIS Online. Simply resaving each domain fixes the issue.

Sue Borchardt

PhD Candidate - Teaching Assistant

Department of Geography, UW-Milwaukee

Assistant GIS Specialist

Cartography and GIS Center - Bolton Hall

DanielArsenault
New Contributor II

I have this exact error, tried this domain trick, didn't work for me.  i use the classic collector version for this layer ...

Kara_Shindle
Occasional Contributor III

I am trying to bring in a WFS we publish from our own server and I am receiving this error.  The other layers hosted on AGOL load fine.  I need to be able to add in services to the collector app from our server, as I cannot edit the domains within AGOL.  

0 Kudos
MArreguin
New Contributor

This solution worked for me. I'm using Field Maps version 22.1.0. 

One view layer in Field Maps wasn't drawing. I added a space to the domain codes and deleted the space, saved, refreshed my Field Map and the view layer started drawing again. Thank You! 

 

0 Kudos
JacquelineMalloy
New Contributor

I have this same issue.  The only difference is the error code I get is 

"Domain: com.esri.arcgis.runtime.error

Code: 10018

Description: bad lexical cast: source type value could not be interpreted as target:"

This is in Portal, not AGOL.  This service includes 3 point layers that are not displaying, and 2 line features that are displaying.  All maps also work fine in Collector Classic.  This same service is on another web map and all layers appear.  I have republished the service and tried the domain trick suggested in the thread and still have the same issue, "Layer failed to load". 

0 Kudos
JeffShaner
Esri Regular Contributor

Hi Jacqueline,

Sorry that you have run into this issue! Code 10018 looks to be a different issue than the domain issue reported above. Can you please log a technical support case so that one of our analysts can document the problem and we can work on a resolution?

Thanks!

Jeff