Labels disappearing in the NEW Collector

05-07-2019 07:20 AM
New Contributor II


We are using the new collector app, not the old one that didn't support labels. 

So I have labels set up for something we call a "location ID" (a 1- or 2-digit number, showing when zoomed out a bit to "building" level) and also for poles (10-digit number, that appear when zoomed way in, to "room" level). Ideally when a person zooms into a location, he or she can see the location ID alongside the pole number.

However I have noticed - and this was not a problem a couple months ago, when I last uploaded layer data for Collector - that our location IDs disappear when zooming in. The pole numbers come in as normal, at the visibility level I set up, but the location IDs disappear well ahead of the pole labels coming on, so there is a zoom level or two where there are no labels at all. 

After testing the only way I can get the location ID labels to remain visible is to turn off the pole number labels. Obviously the two labels are interacting badly, and hopefully someone can help out!


0 Kudos
1 Reply
New Contributor II

The workaround I have discovered is to add a new field with all NULL values. For example, I added a field to my poles called "noLabel" and set the labels to that. When I save the map and then download it, I no longer have pole numbers obscuring or affecting my service numbers.

As for the glitch, I think it's because I published the service layers from ArcMap with pole number labels turned on. I noticed that when I turn off the pole number labels in the AGOL map viewer, the pole number labels still show up on Collector's downloaded/offline map. When I changed the labels to another field, those other values show up as labels in Collector. But when I turn off labels again and save, the labels still show in the offline map. So I can change the labels that show, but I can't turn any of them off. Thus the creation of a new, NULL value field and having my poles be labeled on that.

Furthermore, the layer label settings reset. I may have turned labels off for the poles, but after I save, leave the map, and return to it, I see that the poles have labeling checked on again. So whatever the problem is, it seems that I can't override that "Label Features" check-box.

0 Kudos