How to enable offline mode on a map.

4181
5
Jump to solution
09-08-2016 01:27 PM
MikaylaSeamster
New Contributor II

I shared a map to a group to be accessed in the Collector app but users are not given the option to download the map on their device to use offline. I have researched the issue and the results say I need to make the map Enable Offline usage but I do not see this option in the properties of my map in ArcGIS online. When I created and shared the map in my ArcMap  I checked create, Update, Delete, and Sync so the map should meet the data requirements, but I cannot find the "Enable Offline" option in the setting properties. Any advice would be helpful, we are trying to get the map up and running so we can start field work next week. 

1 Solution

Accepted Solutions
JoeFlannery
Regular Contributor II

Mikayla:

You MUST have an editable layer in your map for Offline capabilities and the layers need to be Sync enabled.  Add a shapefile or a layer from a hosted feature service to your map.  Then make sure editing is enabled for that layer and that "Sync" is enabled for that layer, too.  These things can be enabled in the layer's Item Properties page.

View solution in original post

5 Replies
JoeFlannery
Regular Contributor II

Mikayla:

You MUST have an editable layer in your map for Offline capabilities and the layers need to be Sync enabled.  Add a shapefile or a layer from a hosted feature service to your map.  Then make sure editing is enabled for that layer and that "Sync" is enabled for that layer, too.  These things can be enabled in the layer's Item Properties page.

MikaylaSeamster
New Contributor II

I have an edible feature layer, I also have a shapefile of the study area on the map. The layer is sync enabled and editing is enabled. 

0 Kudos
JoeFlannery
Regular Contributor II

Both layers have Editing and Sync enabled?

These are the only two layers in your map?

What is the source of the "feature layer"?

0 Kudos
JoeFlannery
Regular Contributor II

If the "feature layer" is coming from an ArcGIS for Server service, you need to go into the feature service properties on the server via ArcCatalog, find the Feature Access page and enable Sync there, too.

0 Kudos
MikaylaSeamster
New Contributor II

I had added my shapefile layer straight into the map and not into My Content so the layer was not edible of sync enabled but the map was. Once I added the shapefile layer into my content and then added it into my map I was able to download.  Thank you for your help.