Downloading Offline Maps to Ipad

517
3
10-16-2019 01:09 PM
FranciscoRodriguez4
New Contributor

Hello, 

I am currently using the new data collector app and I am trying to download a map that has 1 feature layer and 8 tables.   he tables are all related to the feature layer using a 1:1 relationship class that uses the feature class Global ID and GUIDS in the tables.   When I try to download the map, the download fails. I have enabled the developer mode and I receive this error message in the Log:

 

"10/16/19, 3:08 PM [4A967132-53C5-4C9C-A7BA-61D1EEFEE7F2] - job failed
10/16/19, 3:08 PM [4A967132-53C5-4C9C-A7BA-61D1EEFEE7F2] - Error downloading map: Error Domain=com.esri.arcgis.runtime.error Code=3079 "Domain already exists." UserInfo={NSLocalizedFailureReason=, NSLocalizedDescription=Domain already exists., Additional Message=}
10/16/19, 3:08 PM [4A967132-53C5-4C9C-A7BA-61D1EEFEE7F2] - Progress: 0.04
10/16/19, 3:08 PM [4A967132-53C5-4C9C-A7BA-61D1EEFEE7F2] - job started
10/16/19, 3:08 PM [4A967132-53C5-4C9C-A7BA-61D1EEFEE7F2] - Message 1/3: Job started."

Once I saw this error and read up on the documentation, I realized that I indeed had fields that shared the same Domain, so  per this recommendation 

• Update the domain names in the geodatabases so that they are unique and republish the layer,

I changed the domain names in ArcPro since I did not use AGOL to create the lists.   I also have made sure that all my fields in both the feature class and related tables are unique.  I generated a list of all the fields and their domains which I have attached here.     Even after these steps I am still getting the same error.  

Some things to note: I cannot publish each layer independently as they are related to the feature class. 

Specs:

Collector (New) App Version: 19.1.0 Build: 2666

Ipad: 6th Generation 

Any help would be appreciated.

-Francisco

0 Kudos
3 Replies
Kylie
by Esri Regular Contributor
Esri Regular Contributor

Hi Francisco - After you republished the data, did you restart Collector and then try to use the map with the republished layer?

0 Kudos
FranciscoRodriguez3
New Contributor II

I restarted the app and turned my ipad off and on. I also tried it in another Ipad.  I also tried to copy the .FGDB and republish the layer, and I still get the same error.  This leads me to think that the underlying schema is not being changed, although the fields and the domains are different when I take a look in ArcPro and ArcMap (I tried publishing from both as well).  Here is the the data if you want to take a look and see if you can replicate the error.  Thanks for your help.   Here is the link to a group I created in case you want to take a look at the data.

https://arcg.is/1aX9SS 

0 Kudos
Kylie
by Esri Regular Contributor
Esri Regular Contributor

Thanks for providing all this! I am able to create preplanned map areas (as part of authoring the map) and those work, but not the areas created in Collector (on-demand offline map areas). However, if I remove the "Septic WasteWaterInfra" table, then I can download on-demand offline map areas in Collector. Looking at the domains in that table, it appears there is a period "." in one of the domain names. My guess is that it might be the culprit -- could you try renaming to remove the "." from the domain name ("DCR FREQ. OF SERVICE") and see if you are then able to create and download on-demand map areas?

0 Kudos