Disable Editing on a Layer

1616
3
Jump to solution
10-24-2014 02:35 PM
TonyGroeneveld
New Contributor III

I want to control which layers the user can edit when using Collector.  Documentation states open map in ArcGIS.com map viewer, click the arrow on the right of the layer and select 'Disable Editing'.

I know I've seen this option in the popup menu before (a couple of months ago), but I no longer see it.

Any thoughts on how to get the menu option to appear in my ArcGIS.com map so I can disable editing?

0 Kudos
1 Solution

Accepted Solutions
TonyGroeneveld
New Contributor III

It turns out my organizational role had been inadvertently changed.  I did not have Edit Features privilege.  Once that privilege was turned on I can now see the ‌Disable Editing‌ menu option.

View solution in original post

0 Kudos
3 Replies
RandyBurton
MVP Regular Contributor

When setting the "Details" of you map in AGOL, there is a set of drop-down options for each layer that includes the choices "Configure Pop-up" and "Disable Editing". To disable only some fields, select the "Configure Pop-up" option, and then click on the "Configure Attributes" link.  You will see a menu that lets you check the fields you want to display and edit. Uncheck the fields where you want to disable editing.

Note:  The "Disable Editing" and "Configure Attributes" check boxes to selectively allow editing are only visible if the layer's properties have been set-up to allow editing in the "My Content" section.

0 Kudos
TonyGroeneveld
New Contributor III

I can see the “Configure Pop-up / Configure Attributes” option but not the “Disable Editing” option.

The layers are coming from our own SDE server as a published feature service. The supported operations for the service are: Query, Apply Edits, Add Features, Update Features, Delete Features, Generate Renderer and Return Updates.

0 Kudos
TonyGroeneveld
New Contributor III

It turns out my organizational role had been inadvertently changed.  I did not have Edit Features privilege.  Once that privilege was turned on I can now see the ‌Disable Editing‌ menu option.

View solution in original post

0 Kudos