Date/Time field not Uptodate - Collector (Android) version

3350
2
06-02-2013 03:21 AM
AdarshMadhavan
Occasional Contributor
Hi,

I had published a service to AGOL and got this service as feature collection layer.

My original service contains a date field .I have not set any default value. When I collect the feature using the collector map , the Date field is coming to Year 1899 .

Its virtually impossible to change to current date.Surprisingly , the in Iphone, the date is coming perfectly.

What would be the issue ? Do I need to set default date to 2013 and publish service again ?
Or something with the Time settings of service in arcgis.com ?

Adarsh
Tags (2)
0 Kudos
2 Replies
LiLin1
by Esri Contributor
Esri Contributor
Hi, Adarsh

I repeated your workflow of a feature class with empty default field type of Date. Published the feature service to ArcGIS.com, make a webmap with this feature service, open it in ArcGIS Collector on my Galaxy Nexus (Android 4.2.1) phone. Collect a new point, tap on the Date field, the date picker is the Android system's date picker with today's date shown.

Could you please tell us what phone you are using? Android version? If possible, could you please share your webmap URL. I will look into it further.

Thank you.

Li
0 Kudos
AdarshMadhavan
Occasional Contributor
Dear Li,

I deleted the date field in the original feature class used for publishing the service and Re-published the service.

This time the "Date" filed behaved properly in the android app.

I do not know what caused the erratic behaviour first time, but I am happy I was able to achieve the result.

Adarsh
0 Kudos