Collector: One table related to multiple Feature Classes

03-20-2018 09:31 AM
New Contributor II

Hi guys,

I am trying to use Collector and related tables in the following way:

I have two Feature Classe: EQUIPEMENTS LEVEL 1 (suppose EQ1_A and EQ1_B)  and one EQUIPEMENT LEVEL 2 (a table, not a Feature Class), let's call this one EQ2

I need to relate both EQ1_A and EQ1_B to EQ2 with a 1:M Relationship Class.

I created GLOBALID in EQ1_A and EQ1_B.

I created a GUID Field in EQ2

I created both the relationship classes (origin: EQ1_A and EQ1_B - destination EQ2 - primary key GLOBALID - foreign key GUID Field).

I published the map with EQ1_A, EQ1_B and EQ2 with ArcGIS Server 10.5.1

I created my map in Portal with all the three classes in the TOC. 

I enabled PopUps

I consumed the map with Collector.

I can see the relationship only for EQ1_A and not for EQ1_B.

Then I tried to create two different Feature Services one with EQ1_A and EQ2 in the TOC, and the other one with EQ1_B and EQ2.

I composed the map with the two different Feature Layers and I am able to see both the relationships.

Is that the right way to manage a table related to multiple Feature Classes/Object Classes in Collecotr? I couldn't find documentation about this particular situation.


0 Kudos
3 Replies
New Contributor II

We noticed this behaviour only on Collector (Windows version). On iOS things are working fine. We'll try on Android, too.

Any comment by ESRI Staff should be great!

New Contributor

We tried to work in our Windows’ Surfaces and several relationship won’t be honored. We did not get any Error when verify the service before publishing.

Then, I read the other comment, and loaded Collector to my iPhone and worked perfect. I can see all the relationships honored to the layers.

I wonder wether someone has reported this already. 

New Contributor III

Saw the same thing today on a Windows 10 device. I can only see one of the related feature layers (the one I cannot edit) and I cannot add a new record to the editable related. On an iPad, it works just fine.

0 Kudos