Collector on iOS not honoring field definitions

3434
9
05-14-2015 01:04 PM
KimberlyDenison
New Contributor

I have a web map containing a feature service hosted in AGO and I have hidden a number of fields in the attribute table.  When I add a point to that FC on Android I only see the 7 fields I left visible.  When I add a point in iOS (iPhone) I still see all the fields.  Same FC, same web map. 

This started after I updated to the most recent version.  Anyone else having this issue?  Is there any way to revert back to the old version of collector if this is a bug?

See Screenshots below.  Note on iOS the Ring_Definition field is showing and it is not in Android.

Screenshot_Android.pngScreenshot_iOS.PNG

Tags (1)
0 Kudos
9 Replies
by Anonymous User
Not applicable

Anyone still getting this? I don't have an Android device. But Collector for iOS is still showing hidden fields.

0 Kudos
AndrewMoffitt
Occasional Contributor III

I am, both in iOS and Android. However, it could be user error on my part.

0 Kudos
RichardFisher
New Contributor III

Yes I have the same issue. iPAD with Collector App showing hidden fields in app display in 10.3.1

0 Kudos
MitchHolley1
MVP Regular Contributor

You can hide fields in the Web App 'Configure Pop-Up' dialog box. 

0 Kudos
RichardFisher
New Contributor III

Thank you Mitch - I am in the Chrome browser (seems more stable than IE for this interface) in the AGOL map for the project under 'Configure Pop-up' / Configure Attributes link with the double row of check boxes and unchecking the 'Display' box and leaving the 'Edit' box checked for the fields I wish to be hidden. They still show up. I am looking at the JSON with the 'ArcGIS Online Assistant' for the same settings for example: and you can see the "visible" : value pair is set to 'false' ... strange stuff.... so the published JSON is valid but the Collector app is not going along with the instructions. ArcGIS Collector version is 10.3.1

Update - I want fields to be edited by the device (geometry type data from R1) but not 'seen' by the user so I choose to hide but leave as editable... when I look at the query display on a collected object the hidden fields are hidden, it is only the fields marked hidden but editable that show when entering data, thus not hidden at that point. So working as designed I assume. Hidden means hidden in the pop-up display not the data entry fields which makes sense as the choices are being set in the 'Configure Pop-up' section.

          {             "fieldName": "RESP_SNOW_ICE_MAINT",             "label": "RESP SNOW ICE MAINT",             "isEditable": true,             "tooltip": "",             "visible": false,             "stringFieldOption": "textbox",             "isEditableOnLayer": true          },
0 Kudos
MitchHolley1
MVP Regular Contributor

You need to uncheck both 'Visible' and 'Editable' if you want the field to be completely hidden. 

0 Kudos
RichardFisher
New Contributor III

I agree - What I was wanting to do (not sure if one can) is for fields that are 'edited' in the background from the GPS device, to have them 'hidden' in the input edit page so the human user didn't have to see the 'clutter' or change the values. I was concerned that if I marked them both not visible and not editable that the GPS unit (R1) would not be able to populate the PDOP, X,Y, and other values even if they are included in the MXD level and just 'hidden' in the application JSON. Not sure how that all works with the settings at each level of the technology each influencing the layer above to a final result.

0 Kudos
Kylie
by Esri Regular Contributor
Esri Regular Contributor

Yes, you can remove the GPS metadata fields from display and during editing if you want to avoid people seeing and changing them. Unchecking edit prevents data collectors from editing values. Check Display if you want them to be visible when viewing the popup details but not editable. See Record GPS metadata—Collector for ArcGIS | ArcGIS 

0 Kudos
NicoleGamble1
Esri Contributor

One thing I notice about your screen shots is that the Android device is only looking at the feature details, whereas the iOS device is already editing the feature. I am wondering if you can try hitting the edit button in the bottom left corner on Android and check if you then see the same fields from the iOS screen capture? Alternatively, in iOS can you try only selecting the feature instead of editing it - are your hidden fields still showing?

From my testing so far, both Android and iOS seem to respect the popup configuration in the ArcGIS Online web map - if you are only looking at the feature details they will show you fields with display checked on, but if you are actually editing the feature they will show you fields with edit checked on. 

0 Kudos