Collector Issues

387
0
07-18-2019 07:09 AM
MichaelSnook
Occasional Contributor III

Hi All

Something has happened that collector will no longer load our layers.  We have a few feature services running on our on-premises external ArcGIS server 10.7 (MSSQL DB) that we are loading into collector (Android) but now they are no longer loading.  We have the service secured using LDAP.  The webmaps are referencing these feature layers and they come in fine in AGO. In collector, they are greyed out in the TOC with no errors of any kind, in collector beta they have an error message 'Attempted to use invalid JSON'.  These layers come in fine in the Windows 10 version of collector but that's not much use.  I've tried paring down all unnecessary fields (null values in dates etc) with no luck.

There are so many little oddities between the versions that it's hard to keep them straight.  It's also frustrating that it seems like Android is an afterthought with multiple new releases for iOS.  It seems like the only thing that works is if we use hosted services created in our AGO account but that is little use with where we need the master data located (on premises).  Any help would be great.

UPDATE: Once I removed the security from the AGS service the layers come in fine in the classic version, in beta, the JSON error is no longer there, and I can toggle the layer on the TOC but they don't show on the map (with just a simple circle symbol). --more oddities!  


After realizing that it was security issue it dawned on me that the cached credentials via our LDAP were out of date (password change policy).  The only way I could find to refresh them was to log out of our organizational account, log back in, re-open the map and re-enter credentials -- works now.  The beta version still shows the 'Attempted to use invalid JSON' message on all layers.  

It would be great if collector would push out a warning if the crednetials were no longer valid for the service and prompt for re-entry...it would also be great if the beta/new version could handle these secured services.

Thanks!

0 Kudos
0 Replies