Collector for Arcgis disconnected Sync error

4539
3
11-04-2014 01:13 AM
SappiGIS
New Contributor III

I am hosting various Feature services from my ArcGIS server to AGOL to be consumed in Collector.  When using the Feature services in a connected environment, all updates can be pushed back to the server without any problems.

The problem start when I download the same map to use in a disconnected environment.  I can capture points and attributes and the data captured get stored on the device, but once I want to sync, the operation takes very long and eventually comes back with a sync error.  This is only on Android devices.  I have tested it on two different Android devices wit the same negative result.  I also tested it on a Apple tablet and the disconnected sync works without any problems.

Can any body assists?

Pieter

0 Kudos
3 Replies
DeniseKing
Esri Regular Contributor

Pieter,

Please email Esri Support and submit your question as Support interaction. Please include complete contact information including Company, Contact Name, Address, Phone and Email Address so you can be input into the system. Then you'll be able to work with Support analyst who specializes in supporting Esri Apps including the Collector for ArcGIS app.

If you have any questions, please email me at dking@esri.com.

Cheers,

Denise

Denise King | Technical Lead - Apps/Mobile

Esri Support Services

3325 Springbank Lane, Suite 100 | Charlotte, NC 28226 | USA

T 704-541-9810 ext 8796 | dking@esri.com | esri.com

0 Kudos
SappiGIS
New Contributor III

The issue seems to be specific to a Web Adaptor limitation, but there is a couple of
workarounds you can look into.  On a slow network or data connections the sync takes along time and then time out.  Thus giving the error.

Workaround 1:

1) Stop the server.
2) Edit the server.xml file in the following location : $\program
files\arcgis\server\framework\runtime\tomcat\conf
3) Increase the connection timeout value of the connector tag to a high value
1000000 :
4) Restart the server.

Workaround 2:

Instead of increasing the connectionTimeout, add a new parameter to '$\program
files\arcgis\server\framework\runtime\tomcat\conf' for connectionUploadTimeout
and set disableUploadTimeout parameter to false.

Workaround 1 worked for us.

jill_es
Esri Contributor

If possible in your environment, you can try accessing your services in Collector through port 6080 or 6443.  This will bypass the Web Adaptor and help confirm if it is indeed the issue.