Collector Edits to SDE. Does SDE need to be 10.2?

3298
5
12-15-2014 11:54 AM
StevenRussell_Jr_
New Contributor III

I am having a problem posting edits from collector to our SDE database.  Our SDE is 9.3, and our AGS is 10.2.  Does SDE need to be 10.2 in order to edit SDE data in collector?

0 Kudos
5 Replies
JoeFlannery
Regular Contributor II

I think you SDE can be 9.3, but your ArcGIS for Server needs to be 10.2.2.  AGS 10.2.2 is the first version where "Sync" could be enabled for a Feature Service.

0 Kudos
JoeFlannery
Regular Contributor II
0 Kudos
StevenRussell_Jr_
New Contributor III

After some testing, it appears SDE needs to be upgraded to 10.x in order for sync to work.  While upgrading server to 10.2.2 allowed the ability to sync data with collector and SDE.  There's a new sync button available.  You need to change your feature classes to archived and unversioned.  To do that requires SDE 10.x.  I am able to version my FC's and archive them.  But i cannot make them unversioned and archived.  I get an error message telling me to update.  Very frustrating, i wish ESRI had posted minimum requirements to use the Collector app.

0 Kudos
847396730
Occasional Contributor III

There is a Collector app feedback email address to which you could suggest they publish a requirements matrix: Collector4ArcGIS@esri.com

0 Kudos
Kylie
by Esri Regular Contributor
Esri Regular Contributor

Yes, ArcSDE needs to be 10.2. The Collector doc is being updated to include this in the January release.

0 Kudos