Collector 10.2.4 - Cannot get web map to appear.

4120
11
Jump to solution
07-21-2014 01:56 PM
MikeQuetel
New Contributor III

Hi,

I've got a webmap that has been shared with a group in our organization.  AGOL accounts within our organization are set up as members of this same group.  When users login to their account they can't see the map in Collector 10.2.4 on iOS.  They can login through a browser, validate membership in the group, see the map and open it up.  Is there any additional criteria that needs to exist for a map to be visible to Collector?

Thanks,

Mike

0 Kudos
1 Solution

Accepted Solutions
RussellRoberts1
Esri Frequent Contributor

The map needs to have an editable feature service and then be re-saved after the  layer is added to the map. Then you can refresh the gallery by doing a pull to refresh.

View solution in original post

0 Kudos
11 Replies
RussellRoberts1
Esri Frequent Contributor

The map needs to have an editable feature service and then be re-saved after the  layer is added to the map. Then you can refresh the gallery by doing a pull to refresh.

View solution in original post

0 Kudos
MikeQuetel
New Contributor III

That works, so thank you very much for the quick reply.  Is that a bug in AGOL and/or Collector or something else.  Not very intuitive to have to do that!

0 Kudos
RussellRoberts1
Esri Frequent Contributor

Its not a bug, we do require an editable feature service to make a map Collector ready. We could make it more visible at the authoring level that the map is ready to be used in the Collector.

0 Kudos
MikeQuetel
New Contributor III

I asked because it did already have an editable feature service in it and had been saved a couple of times.  I just loaded the map, authenticated against the feature service and then saved it again.  Would definitely encourage something that indicates if the map is ready for Collector.  Thanks again!

0 Kudos
PhungLe
New Contributor II

I have a question relating to the same issue.  I did the tutorial on creating a map with Damage Assessment.  The map did show up on the Collector on my iPhone.  However, when I created my own map with added layer of addresses and making the field editable, following the same steps as the tutorial, the map does not appear on my collector.  I have tried refreshing, logged out and logged back in.  The map is shared to the group like the tutorial one.  Still only the tutorial map is shown in the collector and not the new map.  Can you provide guidance?  Thanks.

0 Kudos
RussellRoberts1
Esri Frequent Contributor

Did you make the layer of addresses an editable feature service or did you drag and drop a csv file into the AGOL map viewer? When you drag a file into the AGOL map viewer this creates a layer that is not a feature service and the Collector cannot edit it.

Thanks

Russ

0 Kudos
PhungLe
New Contributor II

I just Added a Layer from File, and imported the file with the list of addresses.  Should I do it differently?

0 Kudos
RussellRoberts1
Esri Frequent Contributor

Yes, When you are under My Content click on Add Item and when you choose Add Item from a file you want to make sure you have the option to publish this service as a feature service enabled. After you created a hosted feature service you will need to click on edit in the item detail page for the service and enable editing and click save.

Russ

PhungLe
New Contributor II

It worked.  Thanks.

0 Kudos