Cannot install on devices that don't have a cellular plan now?

1233
9
01-17-2017 06:37 AM
ThomasColson
MVP Frequent Contributor

I have a large number of Garmin Monterra's where I have previously been able to successfully deploy Collector For ArcGIS. When I went to re-install the app today (newest version) from Google Play, on ALL of the Monterra's, I get a "Application is incompatible for your device (no carrier)" error message, and cannot install the application. The Monterra's all have the latest firmware update and I am able to install other apps from the Google Store. Investigation of this error reveals that "...the application manifest is requiring cellular networking" as a pre-requisite for the app to install. Has ESRI change Collector so it will ONLY work on devices that have cellular wifi and it will no longer work on devices that have just non-cellular wifi?

0 Kudos
9 Replies
JamesTedrick
Esri Esteemed Contributor

Hi Thomas,

The 'No carrier' component simply refers to the fact that it wasn't sold through a mobile phone carrier (there can be subtle differences for a phone model from carrier to carrier in terms of software, radios, etc.).  Can you provide the version of Android that the devices are using?  It doesn't seem to be well documented on Garmin's site; in checking an Amazon Q&A section, there was a reference to Android 4.0.4, which is not a supported version of Android for Survey123.

ThomasColson
MVP Frequent Contributor

Yeah, I'm just getting that from Garmin support. They have no plans to push Monterra-Android updates, which is currently locked at 4.0.4. Very disappointed Garmin customer.....

0 Kudos
AdminJOCC
New Contributor

Did you find any solutions to this?

I just spent the past few months talking this combo up and now that I finally have (2) Monterras I cannot upload the app I sold as being the solution to our needs...

This is beyond disappointing!

0 Kudos
ThomasColson
MVP Frequent Contributor

I've managed to get to a supervisor on the tech support team, my only recommendation is to do the same, and often. 

0 Kudos
AdminJOCC
New Contributor

So were you able to get any of the new ArcGIS apps to work on the Monterra or an older copy from them?

I sent in a question, but haven't heard anything back yet.

Do you have the contact email to pass along?

Thanks

0 Kudos
deleted-user-VvvLP0IsAqjw
New Contributor II

tpcolson‌ - any update on this issue? Seems we have some too and have the same error at 4.0.4.

Thanks,

Susan

0 Kudos
JamesTedrick
Esri Esteemed Contributor

Hi Susannah,

The Garmin Monterra is not a supported device for Survey123.  Survey123 requires at least Android 4.1, as noted in System requirements—Survey123 for ArcGIS | ArcGIS 

Kylie
by Esri Regular Contributor
Esri Regular Contributor

I"m not sure if you are asking for Survey123 (as shown in the image) or Collector, but both require Android 4.1 or later. See Requirements—Collector for ArcGIS | ArcGIS  and System requirements—Survey123 for ArcGIS | ArcGIS

0 Kudos
ThomasColson
MVP Frequent Contributor

We've gotten nowhere with Garmin on this, which is weighing heavily on the probability that I'll continuing recommending them for purchase in the future. 

0 Kudos