Can't add new related record in arcgis collector.

3419
2
04-06-2016 08:20 AM
JaredHarris1
New Contributor

I am currently working the installation of an app for our work force that will to be able to add daily inspection reports at various locations around our city.  I have enabled all attachments within my layers of my service, and checked on all possible user executions of the data...be it to create, update, sync, delete. etc... In Arcgis Online I can view my feature class and access my link to my related table just fine.  Of course you can not edit related tables in arcgis online.  So with Collector I am having an issue, while I can view all my related records and even delete and modify records within Arcgis Collector, I can not create a new related record when I hit the "new" tab at the bottom of my legend tab.   The "view" tab works fine and lets me delete or modify existing records, but I can not create one.  The tab will not even show the circling thinking activation when I hit it like the view tab.  What I am doing wrong? Thanks in advance.

Jared

0 Kudos
2 Replies
ElizabethB
New Contributor III

Jared-

I'm new to editing related tables in Collector, but are you sure you have set up your relationship correctly? If you are trying to add a second record to a feature your relationship has to be 1 to Many, or Many to Many - have you checked to  make sure it is not 1:1?

MicahBabinski
Regular Contributor

Hello Jared,

One thought in addition to Elizabeth's suggestion - are you using an on-premise feature service or an Esri-hosted feature service? It may be necessary to check the permissions on the related table to ensure that your colleagues have the proper insert privileges for that table.

Good luck.

Micah

0 Kudos