Select to view content in your preferred language

Android sync error with arc collector

02-06-2019 01:08 AM
New Contributor

Hi folks,

I am having several problems stemming from not being able to sync data using ArcCollector 18.0.3, build 1033, powered by ESRI ArcGIS Runtime SDK for Android, on two Samsung Galaxy tablets.

I have being doing some research and have discovered several problems that may have contributed to data not being able to sync. Several problems including blue bar not progressing, error message with no details and error message relating to "unable to synchronise replica., importing delta data changes failed". These may be due to the following:

1. Multiple people using the same login details;

2. People not syncing regularly enough;

3. Too many attachments, resulting in data being very large when trying to sync.

Further research has led me to using a USB connection from the tablets to the laptop, where I have been able to see the data stored on the device, which I have copied onto a USB. I then have been trying to run the "copy runtime geoDB to file GBD" tool in ArcMap, with limited success. Some files have copied, some have not. Some have come up with a consistent error message (error 001730), that implies that the runtime GBD is corrupt. My last option is to use a viewer (SQLite client) to open the runtime GBD to see the data inside. However, this is a bit cumbersome, especially since I am using online viewers, due to the work computer restrictions on downloading new programs.

I am just looking for advice on how to extract the attribute data (don't care about he photos anymore) from the corrupt runtime GDB, so that I can export this back into ArcMap. Has anyone got any further advice?

0 Kudos
2 Replies
Occasional Contributor II

Hi Conor,

If you are having problems with syncing from an Android device, you could consider the problem I posted here too:

 I am sorry but I can't help you with the GDB problems. Multiple people using the same login details does not help.



0 Kudos
Regular Contributor

That 0001730 error should be solved by copying the runtime database to the computer you are running ArcCatalog/ArcMap from.

Once you run the tool, you will see your normal attachments table.  You can then use a script provided by Esri to export the attachments out if you need.  How To: Batch export attachments from a feature class in ArcGIS Pro 

I run into sync problems that seem like different problems and we just manually import the data.

Hope this helps.

0 Kudos