An error occurred while synchronizing edits

14965
25
03-27-2014 10:20 PM
BerhanuMekonen
New Contributor II
I tested the offline data collection-Collector for ArcGIS using a future hosted on AGOL, it works well but,  a big but,   am challenged in synchronizing, it move up to 50% and then fail with error massage -
"An error occurred while synchronizing edits"  
Would you please help?
Tags (2)
0 Kudos
25 Replies
RussellRoberts1
Esri Frequent Contributor
Are you using iOS or Android version of the Collector?

Thanks
Russ
0 Kudos
MarcelRamirez1
New Contributor

Hi Russ please I nedd your help in Collector : I've collected and I am trying to sync it back to AGOL. Everytime I try and sync I get the following generic message "Sync Error - An error occurred while synchronizing edits".

I'm using IOS

Thanks

0 Kudos
RussellRoberts1
Esri Frequent Contributor

Do you have a large amount of data that you are trying to sync back to the service?

Are you using Hosted Feature Services from ArcGIS Online or are you using ArcGIS Server Feature Services?

Can you capture the traffic using fiddler to see any error messages come back from the service?

Here is a link to a post on how to configure this:

https://community.esri.com/external-link.jspa?url=http%3A%2F%2Fblogs.esri.com%2Fesri%2Fsupportcenter...

Russ

KevinJohnson15
New Contributor

Thanks

This post really helped!!

0 Kudos
NicholasLaMar
New Contributor II
Hi Russ,

I am having the same problem. I have a map with 10 points and photo attachments I've collected and I am trying to sync it back to AGOL. Everytime I try and sync I get the following generic message "Sync Error - An error occurred while synchronizing edits". Any ideas???

Ryan
0 Kudos
RebeccaHorsburgh
New Contributor II
I too am having this issue. With simple point features and photo attachments. I have 2 separate devices both having the exact same issue. The feature service is hosted on AGOL, I have ensured editor tracking is turned off. We're using Collector for Android on a Sony tablet. One device has 7 features stuck on it and the other has 27. We really need to get them off.
0 Kudos
RussellRoberts1
Esri Frequent Contributor
The upcoming update to the Android app has enhancements to support larger syncs and will help reduce the chances you are seeing these errors. Did you have multiple attachments associated with features with the data collected?

Russ
0 Kudos
RebeccaHorsburgh
New Contributor II

Thanks for your advice Russ. Some features had multiple attachments but not many. As mentioned in another feed i have instructed our users to try and sync back after every 5 features collected if they have phone service. I'm pretty sure this is the issue in regards to the device being an Android and a number of features being collected all with photo attachments.

We eagerly await the Android update.

0 Kudos
RachelWilliams
New Contributor II

I am having this error currently as well. I have 21 points with no attachments and am using Android. It will get up to 50% and then stop. Sometimes it will show as synced, but the features don't show up online and if I close and re-open Collector it shows I still need to sync the 21 points.

0 Kudos