Wire Frames wont turn off

3301
12
Jump to solution
08-05-2015 08:11 AM
JacquelineAlessi
Occasional Contributor

I have a Multipatch model that an outside firm created for CityEngine of our Campus Buildings.

For some reason there is a "wireframe" on the buildings in CityEngine that I cant turn off. It does not show in ArcScene even when I select the object (I was thinking maybe it was part of the geometry.)

I need to turn them off because they are horribly ugly.

In the attached image of one of the buildings the only view setting that is one is texture. If these lines are part of the texture why dont they show in ArcScene?

If I turn the wireframes on the texture on the lines that im calling the "wireframe" appear to become the true wireframe and are shown in black instead of grey.

Further more I cant import any multipatches into CE 2015.0, spoke to ESRI already and the ticket is still open.

1 Solution

Accepted Solutions
by Anonymous User
Not applicable

This should alleviate your problem (hopefully!).

First, make a backup of your scene.

If your buildings are part of the shapes layer, then apply the below rule (also attached).

@StartRule

Shape --> Model.

If the buildings are on the model layer then select them, and in shapes menu, do convert models to shapes, and then run the rule.

Hope this works,

Chris

View solution in original post

12 Replies
DavidWasserman
Regular Contributor

Hi Jacqueline,
Two Suggestions:

1. Check to see that Shaded and Wireframe is turned off. See image below:

2.  If you are concerned that there are too many lines/ or polygons you might want to try applying a rule with a starting clean up geometry function that might help reduce the polygon count of the multipat

I hope the first one solves your problem. The settings shown there are the ones that generally control the view port in CE.
Hope this helps.

David

David Wasserman, AICP
0 Kudos
JacquelineAlessi
Occasional Contributor

Yes the Wireframe on textured IS turned off. I have already ran cleanup Shapes. BUT I cant find solid documentation on how to determine what valuse to use for distance tolerance and angle tolerance. With out more info Im not sure how to determine it... The Help doc says to use the defaults... I bumped them up iterativel untill I got to a distance of 1 and a angle of 10.... No changes what so ever... Im going to keep bumping away and try to see where the tipping point is. Very frustrating. Thank you for your reply.

0 Kudos
DavidWasserman
Regular Contributor

Hi Jacqueline,

How many layers are there in the Scene? Is it just this one?

Do the lines appear in snap shots taken in CE?

Another thing to try is trying to toggle these buttons here:

It is possible that different combinations of the show Shapes vs. Models buttons might get rid of the lines.


Let me know if that helps...

David

David Wasserman, AICP
0 Kudos
JacquelineAlessi
Occasional Contributor

Currently the only other item in the scene is a multipatch that is being used to create a high resolution basemap that originated from a TIN with hard line breaks. I created the Multipatch in house and made sure to use the best practices. The big issue there is that when I start toggling things on and off it effects the appearance of that layer. But I havent had any success with my experiments either. Ive pretty much exhausted the obvious I think.

JacquelineAlessi
Occasional Contributor

btw its all helpful cause at minimum I know that I was moving in the right direction. Im wondering if its a behind the scenes issue with the vendor not meeting the EXACT CE criteria for proper creation :\ which will put a bee in my bonnet to be nice.

by Anonymous User
Not applicable

This should alleviate your problem (hopefully!).

First, make a backup of your scene.

If your buildings are part of the shapes layer, then apply the below rule (also attached).

@StartRule

Shape --> Model.

If the buildings are on the model layer then select them, and in shapes menu, do convert models to shapes, and then run the rule.

Hope this works,

Chris

JacquelineAlessi
Occasional Contributor

Thank you so much worked beautifully and exactly as described!

DavidWasserman
Regular Contributor

Thanks Chris. I was curious if it had something to do with the shape and model layers. At least the general process is outlined in this thread.


Also there are other shape manipulation tools that might be helpful that are spelled out in the documentation. I did not think of it but clean up shapes might help do something similar. I am not sure though.

Chris what does the rule do in this case? Is it just sending it to a empty leaf that casts the shape as it is as a shape rather than a static model?

David Wasserman, AICP
0 Kudos
JacquelineAlessi
Occasional Contributor

Clean up shapes even at the defaults skewed my shapes but looks like in the right scenario would be valuable.

0 Kudos