Webscene weak/slow performance

1256
6
Jump to solution
08-02-2016 02:10 AM
PmssS
by
New Contributor II

Hello Hello,

I have more than 1700 objects that use the rule bellow... and the the performance of the resulting webscene has been reduced drastically with the inclusion of those.

I have seen webscenes of cities with much more objects than I have. and those are working very well.

How can I improve the performance of the webscene?

cheers

Pedro

The rule:

attr containerHeight = 2.6 

@StartRule 

Lot --> 

  extrude(floor(rand(1,5))*containerHeight) 

  print("Height: " +scope.sy +"\nContainers: " +scope.sy/containerHeight +"\n---") #print for control 

  split(y){containerHeight: ColorContainer}* #optional split 

 

ColorContainer --> 

  color(rand,rand,rand) 

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
CherylLau
Esri Regular Contributor

The rule is pretty simple already, so I don't think changing it would help the performance.

The performance also depends on the hardware, so on some machines it may seem slower than others.

I would suggest using the Scene Viewer instead of the City Engine Web Scene Viewer.  I made of test scene of 1750 shapes with your rule, and the Scene Viewer scene has better performance.  File -> Export Models -> Esri Scene Layer Package.  This creates an .spk which you then have to put on your AGOL account (right click -> Share As) and publish (open file in AGOL account -> Publish -> then go to My Content and select the Scene Layer with the same name to open the scene).

View solution in original post

6 Replies
AliciaNewberry
New Contributor III

Have you tried turning off the shadows in the web scene? I've found in my experience that this drastically improves performance.

0 Kudos
PmssS
by
New Contributor II

Hi,

I removed the split and colors.

the shadows are important... I could not remove it.

0 Kudos
CherylLau
Esri Regular Contributor

The rule is pretty simple already, so I don't think changing it would help the performance.

The performance also depends on the hardware, so on some machines it may seem slower than others.

I would suggest using the Scene Viewer instead of the City Engine Web Scene Viewer.  I made of test scene of 1750 shapes with your rule, and the Scene Viewer scene has better performance.  File -> Export Models -> Esri Scene Layer Package.  This creates an .spk which you then have to put on your AGOL account (right click -> Share As) and publish (open file in AGOL account -> Publish -> then go to My Content and select the Scene Layer with the same name to open the scene).

PmssS
by
New Contributor II

Thanks for the answer,

at the moment, after a change, the rule file will random through a set of colours and not all the colours. Besides the intended rule file will be a set of textures (as the name imply in the rule file, it will randomize between types of containers - the typical that are found in storage areas in the ports).

Could you please further explain the AGOL account.

thanks for the help

Pedro

0 Kudos
CherylLau
Esri Regular Contributor

You can publish your web scene by putting the spk in your AGOL account (and then sharing it/setting permissions).  Here's how to sign in (File -> Sign In):

Sign in to Online / Portal 

Here's where to create a free public account:

https://www.arcgis.com/home/signin.html 

0 Kudos
PmssS
by
New Contributor II

well i am still using the CE 2015.1.

And I know the potential of online/portal. But I still need to use the offline as my network does not have access to the internet.

I hear in the last geodesign conference in Netherlands that there are other ways to share the scenes - ArcEarth, maybe other that I don't recall.

but for all that I need a newer version of the CE.

Thanks for the help!

Pedro

0 Kudos