Web Scene Attribute numbers

3256
15
Jump to solution
08-27-2014 01:34 PM
LukeCzar
New Contributor III

HI,

I am having a problems with my attributes, sometimes the numbers look like that " 23.34"  and sometimes like that "23.3400000000000000"

How can I set it only to 2 decimal places so all my attributes will look like that " 00.00"?

The attributes are the same in ArcMap, yet in CityEngine they are not

In the attribute "Height" one building is 23.43 and the other 23.9800000000000

decimals.png

0 Kudos
15 Replies
MatthiasBuehler
Regular Contributor

No, there is not, currently.

Matt

ChrisWilkins
Regular Contributor

If Matthias says it, it is truth! 

0 Kudos
LukeCzar
New Contributor III

Thanks you!!

Lukasz

0 Kudos
LukeCzar
New Contributor III

Hi,

Is it something that might be fixed later on?

Sincerely,

Lukasz

0 Kudos
MatthiasBuehler
Regular Contributor

Hi ..

if you write a short specification on what precise behavior you need, we can send it to Zurich, to the dev team's wishlist.

Matt

Matthias Buehler

Head of 3D Technologies

twitter: @MattB3D

----------------------------------

Garsdale Design Limited

matthias.buehler@garsdaledesign.co.uk

www.garsdaledesign.co.uk

0 Kudos
LukeCzar
New Contributor III

Hi Matt,

The problem is in attributes and how the numbers are displayed in the WebScene, so for example it would be easier if I could specify the format of the numbers 0, 0.0, 0.00, 0.000, 0.0000, because right now some numbers look like that 34.00 and some 34.000000230123

Also, How do I hide the attributes?

@Hidden attr hide_me = 0    <---should It be above the "Lot-->" or below? and should I export it to attributes in order to make it work?

Sincerely,

Lukasz

0 Kudos