SHP import failed - the data is located too far...

3114
4
10-10-2013 06:13 AM
AnteroKeskinen
New Contributor II
Hi Forum users!

I have recently started using CE but haven't got that far yet due to a number of problems in data importing.

First I had problems in importing a DEM & texture (satellite image) but finally managed to import them after reading through some forum topics and finding answers e.g. in http://forums.arcgis.com/threads/54072-textures-raster-files-concepts-in-CityEngine-ArcGIS to use only 8-bit images and resample the satellite image to lower resolution.

However, I cannot import my shp-files to the same scene where I have my DEM and texture. I tried to import them to different scene and did not have any problems; that indicates that the raster and vector data would have different projections. But they do NOT have; I even tried to create a new, empty shapefile by importing the projection settings from the DEM and then creating few polygon features to the shapefile (in ArcMap) but still couldn't open it to the scene having the raster data. Every time CE gives me a message: :import failed, the data is located too far from the current scene etc.....". And since my study area originally covers much larger area, I actually clipped all data by a polygon; that is to say that all data should have exactly the same extent.

So, the main question is how to import the vectors to the same scene with the raster data?

thanks for your help!

-ant-
0 Kudos
4 Replies
MatthiasBuehler1
Frequent Contributor II
hi.

try :

import the shape file in an empty scene. select 1 point, navigate to it ( frame it ), then check the point's vertex coordinates in the Inspectore. Are the values related to lat / long values or actual projected (very big) values ?

if lat/long degree values are interpreted as cartesian values - of course that would be very far away .. :)

let me know.

matt
0 Kudos
vassokosti
New Contributor
Hello!

I have been facing the problem as anthero mentioned above.

I have a georeferenced image and I have digitized vectors in a shape file.
When I export the shape file and I try to import it in the CE scene with the image already imported, the message " import failed, the data is located too far from the current scene " ...

I just did what you told Matthias and one point gives out these coordinates : x =482776.334100008, y =0, z = -4207544.188099861

But I just don't know what to do... Please any help, I would be grateful.
0 Kudos
MatthiasBuehler1
Frequent Contributor II
Hi !

The terrain extent ( size & offset ) must have the same approximate position if imported in separate empty scenes. The coords you mention seem to be correctly georeferenced.

Often, shape files store lat/long degrees instead of cartesian coords ( or vice versa ). So if you get this message, one of the 2 datasets is wrong.

Can you dig a bit deeper ?

Matt
0 Kudos
vassokosti
New Contributor
The problem was solved!

Thank you for your instant answer!
0 Kudos