Not so nice:
myListOfShapes=ce.getObjectsFrom(ce.selection(), ce.isShape)
This would be far nicer:
whatEverIsSelected = ce.getSelection()
myListOfShapes=ce.getSelection(type="Shape")
myListOfModels=ce.getSelection(type="Model")
#filter a selection
myListOfShapes=ce.getSelection(whatEverIsSelected, type="Shape")