Python console error! "Console already exited with value: 0 while waiting for an answer"

797
2
08-05-2020 03:34 AM
Ufuk_Deniz_ÖZTÜRK
New Contributor

I get this error as soon as I turn on the console =

Console already exited with value: 0 while waiting for an answer.

The error comes without writing anything, start with import sys line auto incoming default code

I deleted the program and installed it again and again I got the same error.

I formatted the computer because the Pythons might be overlapping and just installed CityEngine without installing anything, again I got the same error

I thought it might just be on my computer, I installed CityEngine on another computer and got the same error again.

I can't write a python script because of this problem.

0 Kudos
2 Replies
ThomasFuchs
Esri Regular Contributor

Hello Ufuk Deniz ÖZTÜRK

Thank you very much for your report!

Currently I can't reproduce the issue with CE 2019.1. Maybe the connection to Python is blocked by a security setting?


What also would be very interesting to know, if the problem persists with CE 2020.0 . This version is using a new version of the Python development framework. It could be that issue was fixed by the upgrade. 

0 Kudos
Ufuk_Deniz_ÖZTÜRK
New Contributor

Problem is solved. The problem was in the language settings, I changed the windows language from Turkish to English and it was fixed.

0 Kudos