Load 3d models at startup

2926
6
Jump to solution
12-01-2015 06:54 AM
ValerioBozzo
New Contributor III

Hi all. I'm working with a very big scene and I don't want to generate all the 3d models at startup. Unfortunately, every time I open my scene in cityengine 2015.2, It takes a lot of time, and all the models are already generated even if I turn the layers off (in fact, when I activate them again, all the 3d models are already generated). I tried to hide all the layers, then I closed cityengine and started again with layers turned off, but the 3d models are always loaded when I turn the layers on. Is there a setting to avoid 3d models generation at startup?

Thank you, I hope someone can help me....

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
CarlBester1
New Contributor II

Just about to say the same as @Jawadh.

The pop-up looks like this...2015-12-02 09-24-51 AM.png

I assume you ticked on the check-box and said Yes, that is why the pop-up doesn't show at start-up any more. I'm not sure where to reset this option. I would suggest creating a new scene with the same data and rules, and leaving the box unchecked next time.

Good luck

View solution in original post

6 Replies
DavidWasserman
Regular Contributor

Hey Valerio,

Can you take some screenshots of the scene window for us? Are any layers locked or special in some way? Are these procedurally generated or imported building models?

David

David Wasserman, AICP
0 Kudos
ValerioBozzo
New Contributor III

Most of them are procedurally generated with rules, but there are some imported models as well, and some terrain layers. The layers are all unlocked and not visible, but at the startup is very slow becouse i process all the

shapes, even if they are set as not visible. I tried to reset the view-port settings, without success. Any idea?Image 001.jpg

P.S. Is the poligon count too high?

Perspective21.jpg

JawadhHabeeb1
Occasional Contributor

When you open up CityEngine, there will be a PopUp asking you if You want to Generate all the Models, at this point press "No".

Then the scene loads up with the shape files alone, Select the required shape files to regenerate and Press      "Ctrl + G" to regenerate the selected shapes.

Cheers,

CarlBester1
New Contributor II

Just about to say the same as @Jawadh.

The pop-up looks like this...2015-12-02 09-24-51 AM.png

I assume you ticked on the check-box and said Yes, that is why the pop-up doesn't show at start-up any more. I'm not sure where to reset this option. I would suggest creating a new scene with the same data and rules, and leaving the box unchecked next time.

Good luck

ValerioBozzo
New Contributor III

Thank you all. I solved exactly as Carl suggested me. Also, I deleted all the folders exept Esri.lib ( I only left the subfolders named assets, data, maps, rules and scenes). Guess what, the scene now is faster than ever!

0 Kudos
DavidWasserman
Regular Contributor

That should do it. This is why I asked if it was procedural models, but reloaded models I think still need to be imported at the beginning of a scene. Your polygon count was fine. =)
Glad everything is working.

David Wasserman, AICP
0 Kudos