Importing Collida (.dae) files into CityEngine

3070
5
10-01-2012 05:20 AM
AliceDuff1
New Contributor
Hello,

I am having some problems importing .dae files into city engine. I am downloading 3D buildings in London from the Trimble 3D warehouse.. some of the models display fine, but others can only be displayed if I switch the transparency on.

If I turn the transparency off, then they are invisible. I checked one of the models which doesn't display correctly in SketchUp, and it displays perfectly.

Why does it not display in CityEngine, and is there anything I can do to get around this issue?

Thank you.
0 Kudos
5 Replies
AliceDuff1
New Contributor
Some more detail..

I checked, and some of the models I was trying to import had a very complex rating on Trimble.. that made me think that perhaps, CityEngine was unable to cope with complex models. So I tried to load up a model which was classified as "simple" on Trimble, but again, that did not work. It only displays as transparent...
0 Kudos
MatthiasBuehler1
Frequent Contributor II
Hi !

can you point me to the file via PM ?


TIP :
if you import the collada file and check Window > Error Log and get a warning that all faces are transparent then it's the file's fault since it was not written out according to the collada standard which CE uses.

There's some confusion what is transparent and opaque ( 0 or 1).

Lemme know .. :)
0 Kudos
AliceDuff1
New Contributor
Hi!

The file is this one: http://sketchup.google.com/3dwarehouse/details?mid=ca04d433b2a6201d8e2dd5feea45e0e2

Ok, that is encouraging, do you know how i could "get into" the collida file and change the 0 to a 1?

is it easy? I hope so!
0 Kudos
MatthiasBuehler1
Frequent Contributor II
See my other mail ..


Editing Colladas is relatively easy since it's ascii files (pure text). Thus, you can edit it in NotePad by 'search and replace'.

But in your case, I just recommend to get the SketchUp file and re-export it as an other collada file as a triangulated mesh and getting rid of the holes in the polygons. That solves most issues.

cheerio ! :o
0 Kudos
AliceDuff1
New Contributor
Thanks!

It worked!

I imported the model into sketchup, then I followed the guidelines on this video

http://www.youtube.com/watch?v=zYUvox8rSY8

and I exported it to a new .dae file with the triangulate faces option checked!

Thanks!
0 Kudos