I lost the Default Style somehow in CE 2012.1

451
2
03-25-2014 06:51 AM
NicoleMiller
New Contributor III
I had a pretty bad crash and afterwards, CE gets kind of crazy when I try to add a rule or look at any models that aren't created from the geospatial data. All models are completely untextured now. I even tried loading one of the example projects and everything is still a mess. I attached a screen shot of what happens when I try to look at the ModernStreets project. I just tried to reassign modernstreets.cga to bring up the error about the default style. Is there any way I can repair this installation without losing what I have?
Tags (2)
0 Kudos
2 Replies
MatthiasBuehler1
Frequent Contributor II
Hi,


Try:

- close CE, delete the '.cityengine' folder in your user account, restart CE
- create new workspace and try there.

matt
0 Kudos
NicoleMiller
New Contributor III
That did cause me to start a new project but the behavior seems to be similar. I just had it build me a small city and it gave me a ton of "Can't generate geometry" errors.

I didn't really understand them since there were so many, I grabbed one road segment and told it to generate it gave me that same error so I went into the dialog from the log tab.

Under Message: Can't generate geometry. The rule file '/Wizard_Cities/rules/textured_city_day1.cga' contains errors. - [main]

In the exception stack trace: java.lang.Throwable
at com.procedural.cga.CGA.newDerivationAttributes(Unknown Source)
at com.procedural.cga.CGA.newDerivationAttributes(Unknown Source)
at com.procedural.cga.Derivable.newDerivationAttributes(Unknown Source)
at com.procedural.cga.DerivationUIBatch.runGuarded(Unknown Source)
at org.corebounce.ui.GuardedRunnable.run(Unknown Source)
at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:135)
at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4140)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3757)
at org.corebounce.rcp.CBDisplay.readAndDispatch(Unknown Source)
at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2640)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2604)
at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2438)
at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:671)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:664)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
at com.procedural.cityengine.release.Application.start(Unknown Source)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:619)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:574)
at org.eclipse.equinox.launcher.Main.run(Main.java:1407)

Is that meaningful to you? It's suggest to me that I messed up ajava installation somehow. I know less than nothing about java and haven't installed myself it so there must be some java environment somewhere but I haven't the faintest clue which application put it there.
0 Kudos