How do I get split/comp rules to align properly with the world.y extrusion after having the building on the terrain slope?

2146
1
Jump to solution
12-07-2014 05:53 PM
AnnaDang
New Contributor

Hi there,

I have been creating a cga rule for some buildings without aligning it onto the terrain. Therefore I was working on a flat slope and the buildings turned out great.
After it has been align to the terrain, the buildings started to look weird (see attachment) and I'm not so sure how I should get it nicely aligned again.

The extrude function has been changed to world.y but the components and splits still isn't right.

0 Kudos
1 Solution

Accepted Solutions
MatthiasBuehler
Regular Contributor

Hi,

the easiest solution is instead of projecting the shapes to the terrain, use the translate option in the same tool.

otherwise, you can also use

Shape -->

    alignScopeToAxes(y)

    s('1,0,'1)

to flatten the footprint before extruding.

and / or make sure you use extrude(world.y, height) instead of extrude(height) in such cases.

Cheers!

Matt

Matthias Buehler

Head of 3D Technologies

twitter: @MattB3D

---------------------------------

Garsdale Design Limited

matthias.buehler@garsdaledesign.co.uk

www.garsdaledesign.co.uk

View solution in original post

1 Reply
MatthiasBuehler
Regular Contributor

Hi,

the easiest solution is instead of projecting the shapes to the terrain, use the translate option in the same tool.

otherwise, you can also use

Shape -->

    alignScopeToAxes(y)

    s('1,0,'1)

to flatten the footprint before extruding.

and / or make sure you use extrude(world.y, height) instead of extrude(height) in such cases.

Cheers!

Matt

Matthias Buehler

Head of 3D Technologies

twitter: @MattB3D

---------------------------------

Garsdale Design Limited

matthias.buehler@garsdaledesign.co.uk

www.garsdaledesign.co.uk