Height units the rule files from Esri "LumentRT 3D Plants" and "Street Construction"

09-10-2014 07:08 AM
New Contributor

Hello, I am importing LiDAR data from our Land Survey Office in ArcGis to create a DSM and a DTM, then i interpolate then so I can get tree heights, has It worked fairly well so far, one problem is that it seems hard to create Points representing trees in ArcMap on the exact Place on the map where the treetop is. The values that I get I then imported into CityEngine and applied the rule file "Vegetation Library with LumentRT 3D Plants" to create  trees.

I am wondering what height units the rule file from "Esri Vegetation Library with LumentRT 3D Plants" uses? I think read somewhere that they as use meters, so is one 1 height unit value = 1 meter?

My next question is about the rule file "Street Construction" from the  "Example_Redlands_Redevelopment__2013_1", you have the option to add parked cars (and people, both have the same problem) to the side of the streets. When I compare the 3D car model next to a '2D' car in my ortographic photo the

3D car is about 1/2 - 1/3 the size of the one in the Ortographic photo.

I use a ortographic photo from our Land Survey Office as a terrain texture, and it should be properly scaled to the terrain. Is the 3D car perhaps modeled in foot, but that would be strange as the roads seem to be done in meters.

0 Kudos
6 Replies
Occasional Contributor III

Hi Daniel, CityEngine uses meters for everything behind the scenes generally*. This sounds like the issue with both the car and the trees is a unit conversion issue. This might explain why why your cars are 1/3 the size of the models and there are issues with the trees. It might help convert the models in terms of meters, which I know is strange in transportation planning*.

PS: AASHTO Green Book provides most measurements in meters and feet, and CE gave me more appreciation of that fact.

Useful Values (Just to include them):

1 in=0.0254 m

1 ft=0.3048 m

David Wasserman, AICP
Occasional Contributor III


Please notice as an 'fyi' that CityEngine (behind the scenes) always stores stuff in meters. If you e.g. select a vertex of an imported dataset that came from a projection in feet, the coordinate components will still be in meters. Also, the Navigation Display just shows the live-recalculated values in the projection you define in the Navigation Display settings.Means if the SCS is feet-based, the coordinates of the mouse pointer are just recalculated and displayed from the actual metric values.

Matthias Buehler

Head of 3D Technologies

twitter: @MattB3D


Garsdale Design Limited


Occasional Contributor III

Thanks Matthias. Learning everyday.

David Wasserman, AICP
0 Kudos
by Anonymous User
Not applicable

Something else to know is that the OBJ models of the car and people models are in metric, too.

New Contributor

Thank you for your comments! And thank you Mr Buehler for your tutorial videos they have helped me a lot!

What iv'e worked out so far is that all my rule files; LumenRT plants, Street Construction and a building  extrude rule, all gets a scale that is ~0.34 the size of the files imported from ArcGis (in  SweRef99_16_30).

I've tried 3 different terrain maps, one self made from LiDAR, one from Swedens Land Survey Office, and one  from a Univeristy, they all place themselves ontop of eachother and gets the same scale when imported to  CityEngine. They all show the same result.

I've tried 4 different ortographic terrain textures when comparing the scale on the 3D cars to the 2D cars  are from Bing, Google maps, and the Univeristy and the Land Survey Office. They all show the same result  and are correctly placed.

All the files I have imported ArcGis wich in turn comes from universities and Land Survey Offices also are  ~2.94 times larger when compared to the value my rule files. I've noticed that i can set a Georeference in  CityEngine, but SweRef isn't a selectable, though I don't think that should be causing the issue because it  should only affect placement, not scale.

Also I imported Open Street Map files into my project, they had the same scale as my imported ArcGis files.

I made a rule that extrudes building heights and tested it to compare it to tree heights (lumenRT script),  they show the same height, they both had the value 20 from different rule files and they both showed the  exact same height. Then I used the measuring a building in ArcGis and created a "dummy" building in Maya  with those exact numbers, and imported it to CityEngine. Placed it and scaled it to exactly fit ontop of a   building foot print and it was ~2.94 times larger than the extruded building and the trees.

ArcGis 2.94x larger than values from rule files

Rule files 0.34 the size of my ArcGis imported formats.

I can't figure out why my information doesn't scale the same way. Anyone have an idea? I can just multiply all numbers in my rule files by 2.94, but that doesnt feel good, I want know what the problem is.

Daniel Ermebrant

0 Kudos
New Contributor

Correction. my ArcGis material from Swedens Land Survey Office is 1.97 (not2.94)  times bigger than the values in the CityEngine Rule files. So if I make a Terrain file 100x100 meters and have a 10x10 meter high and wide building on it in ArcGis from LiDAR data, and want a rule file that controls any sort of measurements, then i have to multiply those values with 1.97 to make them relative to my model.


0 Kudos