Georeference Export Issues

203
2
01-23-2012 07:43 PM
DanSmith3
New Contributor II
I seem to be posting daily atm! :p

I just want to raise an issue with importing/exporting from scenes using the Australian MGA projection system (GDA 1994 MGA Zone 56). All of my .shp files which are currenlty projected in MGA Zone 56 always default to a custom coordinate system when imported and do not use the predefined coord system. When I then try to export models as COLLADA from the MGA scene they do not end up in the correct geo-position ( In fact they are not even positioned on the globe? ).

I can convert the .shp files to another coord system ( say World Mercator WGS84 ) and then export into the correct position but this results in subtle errors to the shapefiles positioning which is not permissible for my uses.

1. Is there a way I can force CE to use the predefined coord system and not default to a custom system?
2. Are there any known issues with the way CE handles the Australia National Grids?

Cheers,

Dan.
0 Kudos
2 Replies
AndreasUlmer
Esri Contributor
(Problem explanation below)

Solutions
There are several ways to solve this. Choose the one you like best ;)


  1. Export your data to a file GDB instead of shapefile, and use CityEngine's file GDB importer. This importer picks the correct EPSG system, instead of a custom one.

  2. Delete the .prj file before importing the .shp file. CityEngine then asks to choose a coord system. In the top "search expression" field, enter *28356* (epsg code enclosed by wildcard character *), or manually browse to the correct coordinate system.

  3. manually add the epsg code to the very end of the .prj file: change
    ...UNIT["Meter",1.0]]
    to
    ...UNIT["Meter",1.0],AUTHORITY["EPSG",28356]]
    . On shapefile import, CityEngine will pick the correct coord system.

  4. Instead of manually modifying the prj, download the OGC WKT file of your coord system from here http://spatialreference.org/ref/epsg/28356/, and overwrite your current .prj file with this one. On shapefile import, CityEngine will pick the correct coord system.



Explanation
CityEngine uses a different projection and coord sys library than ArcGIS, which can cause issues in some situations. Whenever an authority code (e.g. EPSG:28356) is present in the import data, CityEngine can reliably pick the correct coordinate system. If no authority code is available, picking the "official" (non-custom) coord system is not guaranteed.
Unfortunately ArcGIS shapefile exporter does not write the authority code to the prj file (at least as far as I know), which is why in certain cases manual intervention is required on import, as described above. The File GDB Exporter in ArcGIS on the other hand writes the authority code.
0 Kudos
DanSmith3
New Contributor II
Thanks Andreas!

Did a manual change using Notepad++ but will use the geodatabase option in the future. I have attached a screen capture of part of our static models dataset imported into ArcGlobe, the pipeline from CE to Arc is now running well!

[ATTACH=CONFIG]11413[/ATTACH]
0 Kudos