Select to view content in your preferred language

Geometry problems when exporting from CityEngine to Twinmotion

383
3
04-29-2024 03:15 AM
JulesChasson
New Contributor

Hello,

I'm new to CityEngine, and i created a rule that allows me to generate houses from footprints. I would now like to export them from CityEngine to Twinmotion, but when i do, the walls of the house disappear. The models are exported in udatasmith format. I put screenshots below for you to see the issue.

Here's my cityengine models :

Screenshot1.PNGScreenshot2.PNG

And here are the same models exported in Twinmotion :Screenshot4.PNG

Screenshot3.PNG

Thanks in advance !

0 Kudos
3 Replies
JonasObertuefer
Esri Contributor

Hi @JulesChasson,

Welcome to CityEngine, your rule looks cool!

To further look into your issue can you share the export settings used and the rule file with us? If you don't want to share the rule in this thread you could also send me a DM.

Best
Jonas

0 Kudos
JulesChasson
New Contributor

Hi Jonas,

Thanks for your answer.

Here's my export settings :

JulesChasson_0-1714637037650.png

You can find the rulefile aswell, however i zipped it because the cga format was not supported.

Thank you for your help !

 

Jules

0 Kudos
BenjaminNeukom
Esri Contributor

Hi @JulesChasson 

 

Could you try setting the Material to "two sided" in Twinmotion and check if that solves the problems?

 

BenjaminNeukom_0-1715011584905.png

(Using the material picker and then setting the Two sided flag in the Misc. category).

 

Currently the double sided material flag is not propagated to the Datasmith format from CityEngine. 

 

Let me know if that helps!

 

Best,

Benjamin

0 Kudos