Geometry asset not found

2147
5
07-09-2016 01:06 PM
AndreasForrer
New Contributor

Whenever I'm importing a static object I'm getting this error. This used to work in the past. Any ideas?

0 Kudos
5 Replies
ThomasFuchs
Esri Regular Contributor

Hello Andreas,

Thank you for your report.
To investigate the issue, please provide more information about the file type.

Is there any other information besides "Geometry asset not found" in the error log?
Does it also happen with files created with CityEngine?

Which version of CityEngine are you using?

Thanks

0 Kudos
AndreasForrer
New Contributor

Danke Thomas!

Habe das auf der Website im Chat beantwortet. Toll, dass jemand das liest.

0 Kudos
AndreasForrer
New Contributor

Thanks Thomas.

I was trying to import a valid OBJ or DAE into the Pompeii 2014 scene of Esri CityEngine 2015. The errors I am getting are:

'/Example_Pompeii__2014_0/data/Bridge fixed.obj': Geometry asset not found in ResolveMap. - [Worker-5]

[Method: 'Default$StaticModelOrig'] i(): Asset '/Example_Pompeii__2014_0/data/Bridge fixed.obj' (project ''): error, using 'builtin:unknownasset'. - [Worker-5]

If I try to do the same thing using Pompeii 2011, it works.

So my current workaround is, that I load the object into Pompeii 2011 and then export it as CEJ. When I then load Esir CityEngine 2016 and Example Pompeii 2014, I am able to cleanly import the object and use it.

PS: I appreciate your quick response. Speaks for Esri. I am ok at this point since I figured out a workaround, but obviously something must have changed in the later versions.

0 Kudos
ThomasFuchs
Esri Regular Contributor

Hello Andreas,

Thanks for your response. Glad to hear you already found a workaround.

Generally, the error occurs when the workspace path to the asset file is wrong. In your case the path looks OK to me.

  1. Can you preview the asset '/Example_Pompeii__2014_0/data/Bridge fixed.obj' in the Navigator?
  2. Have you tried both drag and drop and "RMB/Import..."?
  3. Please check the assets workspace path in the inspector. 2016-07-12 14_52_23-CityEngine Advanced 2016.1 - Pompeii.cej.png

I hope this helps you find a better solution.

0 Kudos
AndreasForrer
New Contributor

Ok, thanks Thomas. Moving the object/dae one level down to /data did the trick. Now it works as expected!

0 Kudos