CityEngine to 3D Max - export unit problem

2352
6
06-15-2012 08:19 AM
AleksandarLalovic
New Contributor II
Object exported to 3ds from CityEngine have a totaly weard scale when imported into 3D Max. This wouldnt be such a huge problem if the scaling them manualy in max wouldnt totaly explode the model and make it useless (see the image).

Import dialogue lists folowing options:

1. - Convert Units        : Makes everything 100 times smaller
2. - Dont Convert        : Instead of 1m, objects are 0.0039 m ??? (totaly weard)

System and dispay units in 3D Max are set to meeters.

FBX export also comes 100 times smaller, i have also tryied setting system units in max to cm before import it doesnt help its still 100 smaller.

Thanks
0 Kudos
6 Replies
MatthiasBuehler1
Frequent Contributor II
Hi ..


1]
0.0039 makes absolutely sense if the unit 'feet/inches' are used somewhere.

2.54 cm = 1 inch -> 1/2.54 = 0.3937

2]
read this thread carefully and check in CityEngine, if your projection is using feet.
http://forums.arcgis.com/threads/59442-FBX-export-%28models%29-to-3DSMAX


let me know how it goes ..
0 Kudos
AleksandarLalovic
New Contributor II
Thank you for the quick responce.

I have already read that thread and took care of that a few days ago.

I know its kind of rediculus but my problem is that i cant seem to find out how to set the units in CE? This has realy been buging me for a while now. Do you do it in the preferences or somewhere whithin the code?
0 Kudos
MatthiasBuehler1
Frequent Contributor II
Hi,

Sorry for the late reply.


CityEngine has no settings for the units. By default, CGA assumes your units are in meters, thus, if your dataset is in inches or feet, you need to adapt the attribute values in CGA by adding a correctional factor in the code.

Sadly, we do not yet have a global scale in the Exporter, but I'll try to address this issue again in the team.
0 Kudos
MatthiasBuehler1
Frequent Contributor II
Btw. heard a global export scale is planned
0 Kudos
StevenBoyington
New Contributor
Importing FBX from City Engine 2013 to 3DS Max Design 2014

Although this doesn't make any sense to me, I have gotten the city engine model to scale correctly in 3DS Max 2014 by changing the import presets from Revit to Entertainment and Media. This gives you a 'Units' Panel in the import settings.

Expand the units panel> uncheck 'automatic'> select centimeters (city engine exporter exports in centimeters for some reason)

The scale factor should be 1.0 (this is the part that doesn't make sense to me, you would think it would need to be 100x to make 1 cm into 1 meter)

Be sure that your system units are set to meters, and import and the model should import at the correct scale. It may translate to Imperial units as well if you have it set to feet and inches instead, but I haven't tried that.

Here are a couple screenshots of the settings that worked for me. I am still wondering how....

[ATTACH=CONFIG]30972[/ATTACH]
[ATTACH=CONFIG]30973[/ATTACH]

Good luck

Matt Lukens
0 Kudos
BrianMcAuslan
New Contributor III

Hi, we are having the same issue with reading the fbx file into microstation

needs to be scaled about 0,0 by 100

cheers

Brian

0 Kudos