CityEngine performance expectations?

3703
5
12-17-2014 01:38 AM
BenLeslie1
Regular Contributor

What should my expectations be of CE performance - I'm using 2014.1?

I have Windows XP x64 2003 SP2

Intel Xeon 2GHz 16GB RAM (24 cores)

NVidia Quadro K5000 (4GB)

I find that it copes ok with the graphical hard work - export models, generate, pan, zoom tend to work tolerably.

However things like crtl-A to select all can take a couple of minutes, as can accessing an attribute in the Inspector window (I just see a big black square where all the attribute should be until it refreshes).  I'm currently trying at export 3500 shapes to a shapefile and I've been waiting 35min so far.....still waiting....nearly finished.

I've had problems before with other things in CE but they seem to have been fixed with a change to my network profile, so I'm not sure if this slowness is my machine or CE.

0 Kudos
5 Replies
MatthiasBuehler
Regular Contributor

Hey ..

It's not the computer that is slow, it's the Inspector doing all sorts of evaluations (also to refresh it's UI) that take a long time when you select everything.

Maybe try closing the Inspector pane and see if that changes things ..

Matt

Matthias Buehler

Head of 3D Technologies

twitter: @MattB3D

----------------------------------

Garsdale Design Limited

matthias.buehler@garsdaledesign.co.uk

www.garsdaledesign.co.uk

BenLeslie1
Regular Contributor

Thanks, that's helpul - it certainly seems to help when doing a select all.

But even when I just select a single shape, with the intention of changing attributes, the inspector can take a while to refresh and I get a big black square instead of the attributes - is this normal, can I do anything to help it?

Inspector.jpg

0 Kudos
MatthiasBuehler
Regular Contributor

As far as I know this mostly depends on the complexity of the rules.

Do you have complex rules with multiple imports ?

Matthias Buehler

Head of 3D Technologies

twitter: @MattB3D

-----------------------------------

Garsdale Design Limited

matthias.buehler@garsdaledesign.co.uk

www.garsdaledesign.co.uk

BenLeslie1
Regular Contributor

hmm ok I'll consider that.

Prety sure my rules aren't complex - maybe not written in the most efficient way but no imports.

I have 18 attributes in my rules - about half are object attributes that come from my shapefile, the others are user defined or rule defined.

0 Kudos
MatthiasBuehler
Regular Contributor

Hmm. ok.

Can you maybe do a screen capture video of the behavior ?

Matthias Buehler

Head of 3D Technologies

twitter: @MattB3D

-----------------------------------

Garsdale Design Limited

matthias.buehler@garsdaledesign.co.uk

www.garsdaledesign.co.uk

0 Kudos