CityEngine Layer

660
11
Jump to solution
04-04-2018 02:58 PM
PrasunSaxena
New Contributor II

Hello everyone,

In cityengine, How should I overlap one layer on another layer in scene such that objects in the layer beneath should not be h. hidden

0 Kudos
1 Solution

Accepted Solutions
LR
by
Regular Contributor

There's no draw order, so you'll have to offset your models.

View solution in original post

0 Kudos
11 Replies
Luiz_AmadeuCoutinho
Occasional Contributor III

Could you elaborate more your question? I did not understand. Maybe attach one printscreen or a sample .

0 Kudos
PrasunSaxena
New Contributor II

In this Image I have a map and I want to populate people rule on a portion of map. How to do that?

0 Kudos
PrasunSaxena
New Contributor II

Here I have a map with buildings and other stuffs. I want to populate roads and open area with people. When I do that by creating polygon model and drag and dropping my rule. It shows a grey color rectangle

Is there any other elegant way to populate people in our scene?

0 Kudos
LR
by
Regular Contributor

If you don't use any naked shapes (i.e. shapes without rules applied to them) in your scene, you can turn the shape display off in the viewer options. That'll only leave the models generated on them. If you need shapes visible you'd have to create separate points and load the models through them.

0 Kudos
PrasunSaxena
New Contributor II

Thanks for that solution. Can you tell the process of doing it or any resource I can refer as I am new to cityengine

Thanks

0 Kudos
LR
by
Regular Contributor

To turn off shapes, click here:

To offset your models, add this in your CGA: t(0, somevalue, 0).

To offset the shapes, either move them manually or through the text field on the right.

0 Kudos
PrasunSaxena
New Contributor II

Hey,

Thanks for the detailed description. Also, If I want to creste separate points for my rule. How can I do that

0 Kudos
LR
by
Regular Contributor

Separate points?

0 Kudos
PrasunSaxena
New Contributor II

I have created a polygon shape building in my scene where I have already automatically generated models. When I click on show/hide shapes, my polygon shape model is disappearing but not the generated models. How should I make my polygon shape to do behave same as generated models?

0 Kudos