CE 2015 and 2016 concurrently?

831
2
09-27-2016 07:34 AM
deleted-user-OlpHy1NoMNug
Occasional Contributor II

Is it possible to run CE 2015 and 2016 at the same time?  I need access to 2015 for 3rd party plugin but I get an error about ESRI.lib when I try to open it.

This question was asked previously but was never answered so I thought I would highlight it again.

Scott

Tags (1)
0 Kudos
2 Replies
LR
by
Regular Contributor

You can, but projects saved with 2016 aren't backwards compatible. I also remember getting a message about downgrading esri.lib on another machine, but it's not popping up on the one I'm on right now.. might be due to both pointing at the same workspace.

0 Kudos
CherylLau
Esri Regular Contributor

Yes, you can have CE 2015 and CE 2016 open at the same time.  However, they need to point to different workspaces.  Yes, LR is correct.  The message about ESRI.lib appears when a workspace set up for CE 2016 is accessed by CE 2015, for example.  If you want to go backwards in version, I would recommend having different workspaces for each version of CityEngine since ESRI.lib might not be compatible between the versions.  In fact, different workspaces are necessary if you want to run both version simultaneously.  If you don't want to ever go backwards or open multiple versions at the same time, then maybe having one workspace that keeps getting updated is fine.

0 Kudos