'Align shapes to terrain' icon greyed out

591
3
09-06-2019 08:24 AM
JackCurran
New Contributor III

Hi,

I'm relatively new to CityEngine, so I'm likely doing something a bit newbie-stupid, but...I can't seem to get the 'Align shapes to terrain' icon to become active (or select it from the 'Shapes' drop-down). This was working absolutely fine in my scene previously, but I upgraded to CityEngine 2019 today so I'm wondering if that's something to do with it? Interestingly, most options in the 'Shapes' menu are also greyed out. I've tried it in a completely fresh project (not the one I've imported from 2018.1) and still no luck.

Could somebody tell me what I'm doing wrong please?

Thanks!!

0 Kudos
3 Replies
BurakAydin1
New Contributor III

Hi Jack,

I think it's a street network. So you need to use the symbol "align street graph..." ( 6 symbols left of "align shape to terrain" Symbol)

by Anonymous User
Not applicable

You must select the block shape and use its alignment attribute, as seen below. Or you can run a rule on all of the lots, and "convert models to shapes" to use the "align shapes to terrain", but then adjusting the streets will no longer change the lots. See image:

lot alignments

JackCurran
New Contributor III

Thanks Chris - much appreciated. Good to know about the "convert models to shapes" rule, too!

0 Kudos