Using other than default spatial reference in AppStudio templates

210
4
10-27-2017 07:09 AM
Mads_BøgvadGjelstrup1
New Contributor II

We are planing to use the Map Viewer template (version 2.0) together with web maps with another spatial reference than default web mercator. More specifically we are planning on using web maps based on Spatial Reference: 25832 (ETRS89 UTM32).

 

Is there any known issues with the latest map viewer template using web maps in other than default spatial reference?

Thanks in advance.

0 Kudos
4 Replies
nakulmanocha
Esri Regular Contributor

Are you having issues with a webmap other than web mercator? Currently, I don't have a webmap available in the SR 25832. But I tested with Coordinate system "NAD_1983_Contiguous_USA_Albers" and it worked just fine. If you have a public webmap please list it here. 

-Nakul

0 Kudos
Mads_BøgvadGjelstrup1
New Contributor II

Hi Nakul

Here is one example i have briefly tried which failed:

http://geoinfo-support.maps.arcgis.com/home/item.html?id=dc3696094cdc4aafa29c529ee8e00753 

It is currently used in the following AppStudio MapViewer app:

http://geoinfo-support.maps.arcgis.com/home/item.html?id=f96e60d7917942cd92dcaeadb070f403 

The specific error thrown is "Invalid XML. XML tag not found." when I try to open the web map within the MapViewer gallery. Other web maps based on web mercator opens just fine.

/Mads

0 Kudos
nakulmanocha
Esri Regular Contributor

Hi Mads,

I can reproduce the issue. But this is happening because of WMTS OGC service and not specific to Spatial reference. If you had used an ArcGIS service SR 25832 it should have worked for you. Hence answering your original question that non default web mercator webmaps are supported.

As mentioned it appears to be WMTS OGC specific issue in Runtime. We need to investigate further. Could you please go ahead and create a Esri Support issue under AppStudio stating that WMTS service in Webmap not working within MapViewer.

Thanks,

Nakul

0 Kudos
Mads_BøgvadGjelstrup1
New Contributor II

Hi Nakul

Thank you for your quick replies which have been really helpful. I will share the knowledge with our developers.

I will create an Esri Support issue as soon as possible for this issue.

/Mads

0 Kudos