Microsoft Pen Support in AppStudio 4

122
2
Jump to solution
09-12-2019 12:14 PM
Highlighted

Hello,

I have interested in using the Microsoft Surface Pen on Surface devices for drawing, which I have built into a QML application. I recently installed the new version of AppStudio Player and the pen does not work anymore. The pen doesn't seem to do anything in AppStudio Player at all and I cannot get it to send any mouse or touch events in my application. Before, I believe had AppStudio Player 3.3 installed and the pen worked just as using my finger would on the touch screen. The pen still works as expected in Windows, just not inside the AppStudio Player window. I didn't see any mention of disabling the pen in the AppStudio changelogs, though it is a niche feature.

Is support for the pen something I can expect in the future?

Thanks,

Keith

Tags (2)
Reply
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Esri Regular Contributor

This looks like an issue related to the underlying Qt Framework, check this qt bug related to Surface Pen, https://bugreports.qt.io/browse/QTBUG-77153, and this bug has been fixed in Qt version 5.13.1 and 5.14.0 Alpha.

 

We are able to reproduce this issue using AppStudio 4.0 that includes Qt version 5.12.3, and we also have verified that it is fixed in our AppStudio internal daily build version 4.1 that includes Qt version 5.13.1.

So this issue will be fixed when we release AppStudio 4.1, we are planning to release AppStudio 4.1 by the end of November/early December (**subject to change).

View solution in original post

2 Replies
Highlighted

Does anyone know if I can get the pen to work? I'm wondering if there is a predefined environment variable that will enable it, but unfortunately I cannot find a list of environment variable for QML anywhere. If there is a variable I can set, I will set it in a custom AppStudio Player project and use that to deploy my app. However, there is no way to use the pen anywhere within AppStudio Player.

Any help would be appreciated.

Thanks,

Keith

Reply
0 Kudos
Highlighted
Esri Regular Contributor

This looks like an issue related to the underlying Qt Framework, check this qt bug related to Surface Pen, https://bugreports.qt.io/browse/QTBUG-77153, and this bug has been fixed in Qt version 5.13.1 and 5.14.0 Alpha.

 

We are able to reproduce this issue using AppStudio 4.0 that includes Qt version 5.12.3, and we also have verified that it is fixed in our AppStudio internal daily build version 4.1 that includes Qt version 5.13.1.

So this issue will be fixed when we release AppStudio 4.1, we are planning to release AppStudio 4.1 by the end of November/early December (**subject to change).

View solution in original post