MapTour Template - Story Map not loading

536
7
Jump to solution
07-20-2021 06:29 AM
JoshBillings
Occasional Contributor

Hey all,

I am looking to use AppStudio to create a map tour similar to the Palm Spring tutorial (https://learn.arcgis.com/en/projects/use-arcgis-appstudio-to-build-a-map-tour/). 

When I put in the map tour id (for the StoryMap that I created) into the Properties section of AppStudio and then run the app, the story map doesn't appear and I get a message that says "No Maps to Display." 

Anyone have any suggestions? Thanks!

 

0 Kudos
1 Solution

Accepted Solutions
JoshBillings
Occasional Contributor

Hey Erwin, 

I did end up finding the solution - I was just not putting the "id:" syntax in the query for the map tour. The tutorial didn't include it, so I didn't think I needed it.

Thanks for reaching out!

View solution in original post

0 Kudos
7 Replies
ErwinSoekianto
Esri Regular Contributor

@JoshBillings 

 

I am not aware of any issue similar to what you described. Can you share the MapTour id with us? or maybe work with Esri Technical Support?

 

Erwin.

0 Kudos
JoshBillings
Occasional Contributor

Hey Erwin, 

I did end up finding the solution - I was just not putting the "id:" syntax in the query for the map tour. The tutorial didn't include it, so I didn't think I needed it.

Thanks for reaching out!

0 Kudos
BenSiggery
New Contributor II

Hi there! Mine is doing exactly the same thing. Very new to appstudio so very likely me doing something wrong.

Test MapTour is: https://arcg.is/59n5S ID: 4e42e8aa8eb9424e8da2585e06da8bf5

 

Works fine when I use the Palm Spring example ID but not my own ID.

0 Kudos
JoshBillings
Occasional Contributor

Ben, the tutorial doesn't instruct that the "id:" syntax must be included in the map tour query but it should. That's what was tripping me up.

Additionally, I wasn't able to see your Story Map (it's not shared publicly) so that may also be another issue. The Story Map must be shared publicly before you'll be able to see it in the app.

Hope this helps!

JoshuaBillings_0-1627908490114.png

 

0 Kudos
BenSiggery
New Contributor II

Aha! Working for me now too. Thanks Joshua!

WesleyJohnson
New Contributor

I'm having the same issue despite having added in the 'id:' part. My StoryMap is published publicly and I can pull it up in incognito mode but it won't display on the app when I do a test run. I just get the 'No map tours to display' message. The Palm Springs code works though. Not sure if it's the legacy vs new StoryMaps issue but I can't figure it out. 

 

https://storymaps.arcgis.com/stories/01bd4175054248c998beeb678a83d643 is my test story map.

0 Kudos
JoshBillings
Occasional Contributor

@WesleyJohnson You're right, it's the new StoryMap that is the issue. The app won't accept it. You'll have to use the legacy StoryMaps if you want to include it in your app.

I believe I asked if this would be resolved in the future and I was told it was not part of their plan, if I remember correctly. 

0 Kudos