iTunes Connect: SDK version issue

282
2
06-20-2018 04:54 AM
Highlighted
Regular Contributor

Hi - a question for the AppStudio team. When submitting an app to iTunes that was built with AppStudio v2.x I get the following warning message. Will this be resolved on the build servers before July 2018 (a week or so away).

Dear Developer,

We identified one or more issues with a recent delivery for your app, "xxxxxxxxxx". Your delivery was successful, but you may wish to correct the following issues in your next delivery:

SDK Version Issue - In July 2018, iOS app updates submitted to the App Store will need to be built with the iOS '11.0' SDK or later, included in Xcode [9.0] or later. Make sure to update Xcode for future app deliveries.

After you’ve corrected the issues, you can use Xcode or Application Loader to upload a new binary to iTunes Connect.

Best regards,

The App Store Team

Reply
0 Kudos
2 Replies
Highlighted
Regular Contributor

Hi Paul,

This issue should be solved in the AppStudio v 3.x. You can download v3.x and do Cloud Make again 

Thanks,

Tina 

Reply
0 Kudos
Highlighted
Regular Contributor

Hi Tina

Correct me if I'm wrong, but 3.x no longer supports the 10.2.6 runtime. So would this mean that we can no longer build apps using 10.2.6 after the end of June?

If so, that would be quite a problem as we have legacy applications that we need to maintain.

cheers,

-Paul

Reply
0 Kudos