Invalid Redirect URI in OAuth Sample App

734
2
Jump to solution
01-09-2019 10:28 AM
GiatriLalla
New Contributor III

Good Day,

I am trying to use the OAuth + Biometric Authentication sample app. To do so, I registered a test app, got a Client ID and used that Client ID as prescribed according to the description of the sample app.

"If you wish to use the code from this sample app, please update Client ID with your own at MyApp.qml file, line 109"

I got the error below. How can I fix this? (P.S. I am not the ArcGIS organization's administrator etc. so I can not do any type of changes)

0 Kudos
1 Solution

Accepted Solutions
NakulManocha
Esri Regular Contributor

Did you register it from AppStudio desktop app settings or directly on the developers.arcgis.com? If you did it on developers.arcgis.com please add the redirect uri - urn:ietf:wg:oauth:2.0:oob as mentioned in the following help

Sign your app—AppStudio for ArcGIS | ArcGIS 

Nakul

View solution in original post

2 Replies
NakulManocha
Esri Regular Contributor

Did you register it from AppStudio desktop app settings or directly on the developers.arcgis.com? If you did it on developers.arcgis.com please add the redirect uri - urn:ietf:wg:oauth:2.0:oob as mentioned in the following help

Sign your app—AppStudio for ArcGIS | ArcGIS 

Nakul

View solution in original post

GiatriLalla
New Contributor III

Thank you! This works perfectly! I registered via developers.arcgis.com and after adding the redirect uri it worked.

I wish I found this piece of help earlier on. It would have saved so much time. Thank you again!

0 Kudos