Installing APK's on Android Emulator(s)

2100
2
06-01-2020 02:08 PM
JohnLivengood
New Contributor III

I have downloaded various android virtual devices to test out a map viewer template (4.2).  Nexis, Pixel, etc. including multiple API's (27, 29).  I've used cloud make to build signed APKs (ARMv8 and ARMv7).  I can't get the APK's to install on the virtual devices though.

I've uploaded the APKs to google drive and typed in the URLs on the virtual devices, downloaded the APKs but it will just say app not installed. 

I tried using Android Studio and received the error.  

Installation did not succeed.
The application could not be installed: INSTALL_FAILED_NO_MATCHING_ABIS

Any tips on how to install an APK on one of these devices?

0 Kudos
2 Replies
ErwinSoekianto
Esri Regular Contributor

John,

The error you are getting, INSTALL_FAILED_NO_MATCHING_ABIS, is caused by when you are trying to install an app that has native libraries and it doesn't have a native library for your CPU architecture.

This is because AppStudio Cloud Make only supports ARM-based build (ARMv8 and ARMv7), where the Android Emulators are running on the x86, so they are not compatible. 

The workflow for testing in Android Emulator is to test it using AppStudio Player (x86), which should be installed in the emulator if you launch the emulator from AppStudio Desktop. 

 

Thank you,

Erwin

0 Kudos
JohnLivengood
New Contributor III

Thank you Erwin.  I have tried using AppStudio Player to test the app on the virtual devices.  The issue was the buttons are always black boxes and occasionally have a blue transparent box along the top of the app.  Functionality wise it's OK but for screenshots it's a no go.  

I don't have the same issues using AppStudio Player on physical devices.

0 Kudos