Enable Attachments with Restricted Editing

645
6
Jump to solution
12-12-2019 06:02 PM
OrloDennison
New Contributor III

Hi

Are there any plans for Quick Report to support the feature layer edit settings below - with attachments enabled. I understand that Survey123 supports attachments with this particular editing configuration.

Currently I cannot add attachments unless 'Add and update features' is selected, which disables the 'can't see any features' option.

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
ErwinSoekianto
Esri Regular Contributor

Orlo, 

We tried to experiment trying to accommodate these editing settings.  If you are interested you can try by updating these three files below. 

- QuickReportApp.qml

- controls/FeaetureServiceManager.qml

- pages/SavedReportsPage.qml

Please note that your feature layer must have Global IDs field, to be able to work with this. 

Let me know if this is working with your feature layer. 

Thank you, 

Erwin

View solution in original post

6 Replies
ErwinSoekianto
Esri Regular Contributor

Orlo, 

I just tested this using a feature layer with that particular editing configuration, "Add features" and "Editors can't see any features, even those they add" with Quick Report template with AppStudio Desktop 4.1, and it is working. 

This is the sample feature layer that I am using, https://services1.arcgis.com/e7dVfn25KpfE6dDd/arcgis/rest/services/MapTour_StoryMap/FeatureServer/0 

Thank you,

Erwin

0 Kudos
OrloDennison
New Contributor III

Erwin,

Thanks for looking into this. I used your feature layer in a fresh sample Quick Report template but still encountered an error when adding attachments. I also tried adding the feature layer to a web map and experienced similar behavior where the feature gets created but the attachment doesn't get added.

0 Kudos
ErwinSoekianto
Esri Regular Contributor

Orlo, 

My apologies, you are right. It was working when the service was not shared publicly. This is not working when we are adding new features anonymously. 

 

But I am not getting an error, but the upload button for the attachment keeps spinning. It looks like this is the error I am getting in the code, 

"{"error":{"code":400,"message":"","details":["This operation is not supported."]}}"
This is the setting for it to work, 
We are currently looking into this, to see if we can make it work with "Editor can't see any features, even those they add". 
Thank you,
Erwin
0 Kudos
OrloDennison
New Contributor III

Thanks Erwin.

It looks like this is common behavior for hosted feature layers but I was hoping Quick Report could bypass this issue in a similar way to what the Survey123 app does. It would definitely make things easier for securing sensitive information within an editable publicly shared layer or layer view. 

0 Kudos
ErwinSoekianto
Esri Regular Contributor

Orlo, 

We tried to experiment trying to accommodate these editing settings.  If you are interested you can try by updating these three files below. 

- QuickReportApp.qml

- controls/FeaetureServiceManager.qml

- pages/SavedReportsPage.qml

Please note that your feature layer must have Global IDs field, to be able to work with this. 

Let me know if this is working with your feature layer. 

Thank you, 

Erwin

OrloDennison
New Contributor III

Thanks Erwin. This works a treat. Much appreciated

0 Kudos