Appstudio Custom App not able to run on IOS

356
2
11-07-2017 07:49 AM
RaulLeos
New Contributor II

I have developed a custom for our organization with Appstudio 1.4. I ran through all steps purchased a develpeers license got Apple Developer subscription and also created all the certificates, provisioning and p12 files necessary to complete the make of this custom app. I got the zip files back from Appstudio with no issues. I was able to run the windows executable file on desktop and tablet with no issues but when I try to install the .IPA file format for IOS, I have issues even to install or run. I have tried doing the install using ITUNES on MacBook or IPAD and no success. I need some help to determine if its something to do with operating system upgrade on IOS or devices. Please help!!

Tags (1)
0 Kudos
2 Replies
LiweiGao
New Contributor II

Hi,

To install and run the app on iOS devices is very easy.

If you just want to test the app, I suggest you use AppStudio Player. You can know more for AppStudio Player by watching the video from our workshop Chapter 3.1 Testing, Building, and Distributing Your Apps | Testing (1 of 5) - YouTube. In this way, you don't have to do the cloud make for your apps every time. All you need to do is loading the app inside the player.

However, if you really want to install the real app, you can do the build on the fly and installed the app via AppStudio OTA. Here are the steps:

- Build the app

- On iOS device, use browser to visit the website https://appstudio-ota.arcgis.com/#/ and log in with your account

- Install the app by clicking the "install" button via AppStudio OTA 

This will install the app for you on iOS devices.

Hope this will help!

0 Kudos
RaulLeos
New Contributor II

Hello,

thank you for reaching out and helping me on this matter. I was able to install the app on the IOS device with no issues after I remove the module ArcGIS.AppFramework.Runtme.Webmap 1.0. but I will try and do what you mentions on this comment. 

Now I running into a new issue my app does not run for testing on AppStudio for ArcGIS desktop standard license. Do you know if the version I am running might be the problem. Please let me know what module or anything that I might need to upgrade.

Thank you for all your help.

Raul

0 Kudos