After upgrading AppStudio & Runtime, app no longer runs in background

580
5
03-20-2017 12:09 PM
KenGorton
Esri Contributor

I have an app I wrote in Qt Creator that for months ran reliably when backgrounded on my iPhone. Just recently I upgraded AppStudio to v 1.4 which also laid down AppFramework 1.4.18, Qt version 5.8.0 and ArcGIS Runtime SDK for Qt version 10.2.6.1628.

After re-Making my app and redeploying it, it no longer runs when backgrounded on my device. I may have made some inadvertent change but don't think so. I have verified  "backgroundLocation": true, in appinfo.json but have no idea what else to check.

What would cause it to no longer function while backgrounded?

Any and all help appreciated.

Thanks,

Ken

0 Kudos
5 Replies
AMathur
Esri Contributor

Hi Ken,

We tried to recreate the issue at our end and we are able to reproduce it with AppStudio 1.4. The setting that you have in appinfo.json is correct. Can you also confirm that you have the environment setting APPSTUDIO_POSITION_BACKGROUND_MODE set as ON in the Environment tab in the Settings tool.

Our dev team is investigating the issue as of now and we'll get back to you once we have narrowed down the cause for it.

Thanks,

Anshuman

0 Kudos
KenGorton
Esri Contributor

Thanks Anshuman

Yes, I have APPSTUDIO_POSITION_BACKGROUND_MODE set to ON:

Let me know if there are any work arounds or solutions you can think of.

Best,

Ken

BTW Where ate the APPSTUDIO environment settings documented? Or are they?

0 Kudos
AMathur
Esri Contributor

Hi Ken,

 

Setting the environment variable APPSTUDIO_POSITION_BACKGROUND_MODE is a beta fix that is still under development. We have to set this only in case of iOS and it is possible that in future that we may not need to set this variable at all. That’s the reason we have not formally documented it yet. I'll keep you updated in case there are changes in the implementation.

 

Thanks,

Anshuman

0 Kudos
PimJanissen
New Contributor II

Hi there! I am currently trying to see if it's possible to update the gps location in the background (and catch the onPositionChanged event), which led me to this thread.

I'm trying to run the location in the background atm on an Android device and it does not seem to be working. Is that due to this issue?

0 Kudos
NakulManocha
Esri Regular Contributor

Yes, because it is not currently available for Android. With the upcoming release we will be officially supporting this feature out of the box for Android and iOS.