'WebMap' object has no attribute 'layers'

1126
2
Jump to solution
03-22-2018 02:24 PM
MarkCederholm
Regular Contributor II

Does a portal have to be at a specific version in order for the API to work? I can connect to my portal and search for items, but when I create a WebMap from an item, nothing shows:

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
AtmaMani
Esri Contributor

Mark, your Python API install has to be version 1.3 or higher for this functionality. We just released v1.4, so I recommend upgrading your conda install: Install and set up | ArcGIS for Developers 

View solution in original post

2 Replies
AtmaMani
Esri Contributor

Mark, your Python API install has to be version 1.3 or higher for this functionality. We just released v1.4, so I recommend upgrading your conda install: Install and set up | ArcGIS for Developers 

MarkCederholm
Regular Contributor II

I see.  I didn't look closely enough through all the directions.  There is a logical glitch at

Get Conda with ArcGIS Pro

0 Kudos